Ask Your Question
0

kde-connect, firewall policies and connection problems

asked 2016-09-30 17:26:31 -0600

dave997 gravatar image

Hi there,

after a few emails exchanges with the developer of the KDE-connect application for Android, I've decided to report here the problem, as suggested.

Put briefly, some weeks ago I reinstalled Fedora 24 KDE after some months of use, set everything up again and immediately noticed that KDE-connect was not working any more. I spent some hours making all possible attempts to get it functional without success, then finally gave up - and ended thinking some update had messed up something.

Reality was actually different. When I reinstalled Fedora (using the latest iso), the kde-connect entry in the Firewall settings -> zones -> services was unmarked by default, contrarily to what happened months before with the first install. I don't think this could be seen as a good choice, since such a change of behavior is practically impossible to reveal - and creates problems. In fact, it was actually a case if I discovered what was preventing kde-connect from working.

Personally, I have no more problems henceforth, since I know the story.. So, just out of curiosity and hoping to help someone else, is my firewall behaving not as expected? Maybe my previous Fedora installation (which was on a USB HDD) somehow prevented firewalld from working, hence kde-connected worked immediately? And finally, assuming this being a bug, should I report it to the official Red Hat Bugzilla? Should this be the case, I'd be glad if some more experienced user could give some advice in order to make a useful, visible report (where, how, etc.).

Thank You all, David

edit retag flag offensive close merge delete

Comments

Welcome to Ask Fedora, David. I hope you’ll stick around.

Aeyoun gravatar imageAeyoun ( 2016-10-03 05:13:35 -0600 )edit

Sure. I've had much more things to do this month than usual so stayed away for while, but I wasn't going to leave this Forum:)

dave997 gravatar imagedave997 ( 2016-11-09 11:28:56 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-03 05:13:10 -0600

Aeyoun gravatar image

This is indeed a bug with Fedora’s kde-connect package and you should indeed report it. I ran into the same problem a few month back when working on my review of KDE Connect. — the problem here is that consumers are unlikely to properly configure their firewall zones, so only enabling KDE Connect when you’re on your home- or other trusted network is kind of difficult. It’s broken by default, however, so it’s a bug by definition.

edit flag offensive delete link more

Comments

Thank you, @Aeyoun . I've sent a report at Fedora Bug Report. Let's hope this helps! (developers, users..)

dave997 gravatar imagedave997 ( 2016-11-09 11:33:05 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-30 17:24:37 -0600

Seen: 1,193 times

Last updated: Oct 03 '16