Ask Your Question
0

How to install JRE and JDK for Zimbra Desktop on Fedora 24

asked 2016-09-28 03:58:02 -0600

gezafa gravatar image

When I install Zimbra Desktop on Fedora i got a message :

WARNING: ia32-libs is missing for x86_64 platform. This package is required to run Zimbra Desktop on 64-bit Linux.

Java SE Runtime Environment (JRE) not found. Please install JRE 1.6 or later.

Could you help me, how to install it?

Because i already download java "jre-8u101-linux-x64-1.rpm" and install but the message still appear.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-09-28 14:29:30 -0600

beduine gravatar image

updated 2016-09-28 14:30:49 -0600

I prefer the following way:

  • download the jdk-8u101-linux-x64.tar.gz
  • extract it to /opt
  • export the PATH in your shell and then start the tool export JAVA_HOME=/opt/jdk1.8.0_101 && export PATH=$JAVA_HOME/bin:$PATH

Maybe you can also set the JAVA_HOME in your Zimbra-config.

edit flag offensive delete link more
0

answered 2016-09-29 09:47:12 -0600

bsch gravatar image

I have had the same problem with Zimbra Desktop since at least Fedora 22. I just managed to work around it by doing the following. Note: I do not claim that my solution is correct or that anyone else should follow it.

  1. Inside the newly-downloaded/extracted directory containing the Zimbra app, open the script install.pl in a text editor and remove the "exit;" from the line: "else { print "Java SE Runtime Environment (JRE) not found. Please install JRE 1.6 or later.\n"; exit;}". This will prevent the installation from exiting, if the installer does not detect the appropriate java version in your system.
  2. Install the app by running the script, as explained in the Zimbra documentation.
  3. Run the user-install.pl according to the documentation.
  4. If you have followed beduine's answer above, it means that you will have the 32-bit JDK version in your /opt/ directory. You will need to point to this java version in the following two files: "/opt/zimbra/zdesktop/data/bin/zdesktop" and "/home/user/zdesktop/bin/zdesktop". To do this, simply comment out the line JAVA=which java and add the line JAVA="/opt/jdk_directory/jre/bin/java".

    You may need to install some extra packages, so it is probably better to run Zimbra from the terminal and look for missing packages-related warnings/errors.

    Hope this helps.
edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-09-28 03:58:02 -0600

Seen: 1,744 times

Last updated: Sep 28 '16