Ask Your Question
1

Lag after waking up from sleep

asked 2016-09-25 09:32:58 -0600

skamath gravatar image

updated 2016-09-26 01:10:45 -0600

I am currently running Fedora 25 and I am facing this weird issue of lag after waking up my laptop from sleep. After waking up from sleep, the system randomly freezes for a while. During this freeze duration (which generally lasts for about 2 seconds) , my keystrokes are repeated.

Relevant info :

$ uname -a

Linux localhost.localdomain 4.8.0-0.rc2.git3.1.fc25.x86_64 #1 SMP Fri Aug 19 14:24:04 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Memory / CPU usage looks normal to me.

EDIT :

Installed htop and sorted processes wrt to the CPU usage. Looks like gnome-shell is the culprit. When the lag happens, gnome-shell uses about 90-99% of the CPU. Is this some bug with gnome-shell?

Some useful info :

glxinfo | head -n 50 :

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_fbconfig_float, GLX_ARB_framebuffer_sRGB, GLX_ARB_multisample, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_create_context_es_profile, 
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_OML_swap_method, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
    GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_buffer_age, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_create_context_es_profile, GLX_EXT_fbconfig_packed_float, 
    GLX_EXT_framebuffer_sRGB, GLX_EXT_import_context, 
    GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
    GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_fbconfig_float, GLX_ARB_framebuffer_sRGB, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_buffer_age, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_create_context_es_profile, 
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
    GLX_SGI_video_sync
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) Kabylake GT2  (0x5916)
    Version: 12.0.1
    Accelerated: yes
    Video memory: 3072MB

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)

lspci | grep 3D

01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-09-25 19:07:57 -0600

Aeyoun gravatar image

Without more information it’s a bit difficult to tell, but I’ll take a guess and say you‘re retrieving memory swap from disk to memory. This is expected to be slow and behaves exactly the way you describe. The GNOME System Monitor can tell you more about your memory and swap memory. Leave it open, put your laptop to sleep, give it a few minutes, and then have a look at it again when you wake up your laptop again.

edit flag offensive delete link more

Comments

Hi, I have not configured swap for my device. I have around 8GB of RAM at my disposal so I don't really need swap. From what I noticed in GNOME System Monitor, one of my CPU spikes to 100% usage when this happens.

skamath gravatar imageskamath ( 2016-09-26 00:50:47 -0600 )edit

I used to have this issue, then I configured a swap partition and now it works fine. Maybe try that?

mikechav gravatar imagemikechav ( 2016-09-26 10:50:43 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-25 09:32:58 -0600

Seen: 804 times

Last updated: Sep 26 '16