Ask Your Question
0

Cannot build Aegisub in Fedora-configure error: Aegisub requires that boost be built with ICU support

asked 2016-09-20 06:14:52 -0600

powergame gravatar image

I am trying to build Aegisub for Fedora 24. Although I have had a successful build experience of this application with Fedora 22, I fail to do so in Fedora 24. The error I receive while running ./configure in the root directory of aegisub--3.2.2 source tree is:

checking for boostlib >= 1.50.0... yes
checking for exit in -lboost_chrono... yes
checking for exit in -lboost_filesystem... yes
checking for exit in -lboost_locale... yes
checking for exit in -llibboost_regex.so... no
checking for exit in -l/usr/local/lib... no
checking for exit in -lboost_thread... yes
checking boost/spirit/home/phoenix/version.hpp usability... no
checking boost/spirit/home/phoenix/version.hpp presence... no
checking for boost/spirit/home/phoenix/version.hpp... no
checking for ICU_UC... yes
checking for ICU_I18N... yes
checking whether boost ICU support works... no
configure: error: in `/home/mhd/src/aegisub-3.2.2':
configure: error: Aegisub requires that boost be built with ICU support.
See `config.log' for more details

Actually, I have tried both installing boost from Fedora repositories and also by building boost myself, but it does not work. I also built and installed icu before building boost, but none of them were effective in solving the problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-09-20 07:23:24 -0600

fcomida gravatar image

boost-regex is missing. You also need ffms2 on linux.

edit flag offensive delete link more

Comments

With --with-boost=/usr/local, it finds boost-regex, but still complains about lack of ICU support. Here is the output for ./configure --with-boost=/usr/local.

powergame gravatar imagepowergame ( 2016-09-20 07:54:13 -0600 )edit

checking whether boost ICU support works... yes

boost-regex-1.60.0-7.fc24.x86_64 libicu-devel-56.1-4.fc24.x86_64

fcomida gravatar imagefcomida ( 2016-09-20 09:15:09 -0600 )edit

These two packages are already installed, yet the build fails.

powergame gravatar imagepowergame ( 2016-09-20 14:17:13 -0600 )edit
1

well i showed you configure succeeds in my system, of course do not use the boost version you compiled (no --with-boost=/usr/local). Check config.log as well maybe other *-devel packages are missing in your system

fcomida gravatar imagefcomida ( 2016-09-20 18:46:06 -0600 )edit

Thank you @fcomida I will keep looking.

powergame gravatar imagepowergame ( 2016-09-21 10:33:22 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-20 06:14:52 -0600

Seen: 362 times

Last updated: Sep 20 '16