Ask Your Question
0

Wrong MTU for pppoe

asked 2016-09-20 07:37:35 -0600

Sergey2016 gravatar image

Hi,

I don't know whether this is a bug or not, I'm not a network specialist, but since some update, Network Manager sets incorrect MTU value for my DSL connection. MTU change in the Network Manager from auto to 1492 under Ethernet tab for both enp4s0 and the connection doesn't help. Adding MTU=1492 to etc/sysconfig/network-scripts/ifcfg-enp4so doesn't help either. The solution for me is to run "ip link set mtu 1492 dev enp4s0" in the terminal on every boot. So the question is: Is there another solution that would set MTU permanenetly?

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-09-21 15:35:46 -0600

sixpack13 gravatar image

updated 2016-09-22 08:26:30 -0600

FranciscoD_ gravatar image

you are correct, sysctl --system with an extra file under /etc/sysctl.d/ doesn't change anything.

SORRY !!! My bad. BUG / Feature / PEBKAC ???

please delete your /etc/sysctl.d/100-my-MTU.conf !

what's about an rc.local ? place a file called rc.local with the following text under /etc/rc.d/

#!/bin/bash
touch /var/lock/subsys/local
ifconfig enp4s0 mtu 1492;
exit 0;

rights and ownership should be this:

-rwx------. 1 root root 4,6K  4. Jun 19:56 rc.local

reboot or su -c 'source /etc/rc.d/rc.local'

check your MTU with ifconfig | grep mtu OR tracepath ask.fedoraproject.org

edit flag offensive delete link more

Comments

Thanks, this works perfectly! MTU is set to 1492!

Sergey2016 gravatar imageSergey2016 ( 2016-09-21 21:17:35 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-20 04:05:25 -0600

Seen: 423 times

Last updated: Sep 22 '16