Ask Your Question
1

How to use nemo instead nautilus on Fedora 18?

asked 2013-02-01 17:34:35 -0600

Nelson Caballero gravatar image

updated 2013-02-02 05:04:05 -0600

hhlp gravatar image

I installed nemo packages, but I don't know how to set Nemo as default. Any ideas?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-02 05:03:29 -0600

hhlp gravatar image

updated 2013-02-05 15:07:07 -0600

you can install and set nemo as default file manager follow this guide :

  1. Nautilus features gone in Fedora 18
- sudo yum install nemo
- xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
- gsettings set org.gnome.desktop.background show-desktop-icons false
- Turn on the option "Have file manager handle the desktop" in gnome-tweak-tool
edit flag offensive delete link more
1

answered 2013-02-05 15:40:47 -0600

ryanlerch gravatar image

Nemo is a fork of Nautilus that keeps some of the features that were removed in Nautilus for the 3.6 release of GNOME. This post gives a good overview of some of the other reasons why people might want to change to Nemo over Nautilus -- http://cinnamon.linuxmint.com/?p=198

Installing the Nemo File Browser

Luckily, in Fedora 18, nemo is available in the Fedora repositories, so installing it is as simple as searching for nemo in Add / Remove Packages, or running:

yum install nemo

from the command line.

Once installed, you will be able to run nemo as a secondary file browser. Just search for nemo in the overview. It should show up as "Files" with a Folder icon, rather than the Filing Cabinet icon of Nautilus.

Using Nemo as Default File browser

Setting up GNOME to replace nautilus with nemo as the default file browser is a little bit more involved. First you need to start up the gnome menu editor, alacarte (yum install alacarte if you haven't previously installed it).

Once you have alacarte running, in the right hand pane, choose the Accessories category. The right hand pane should list two items with the Label "Files".

image description

Disable the nemo entry (the Files entry with the folder icon) by deselecting the checkbox beside the folder icon. Next, edit the nautilus entry (the one with the Filing Cabinet icon), by selecting it, and choosing properties.

In the Dialog that pops up, change the command from "nautilus %U" to "nemo %U"

image description

This should result in GNOME bringing up nemo rather than nautilus in most circumstances.

hope this helps, ryanlerch

edit flag offensive delete link more

Comments

thanks...it works

tony gravatar imagetony ( 2014-08-17 00:00:54 -0600 )edit
0

answered 2015-02-10 12:25:18 -0600

as root type cp /usr/bin/nemo /usr/bin/nautilus basically overwrites the nautilus executable with nemo, so even if nautilus is ever called, nemo will start instead

edit flag offensive delete link more
0

answered 2015-10-11 11:24:06 -0600

MrAmbiG gravatar image

apparently the latest version of gnome-tweak-tool has an option to enable it in 2 places. gnome-tweak-tool>widnows>maximize>on gnome-tweak-tool>widnows>minimize>on gnome-tweak-tool>widnows>middleclick>minimize

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-02-01 17:34:35 -0600

Seen: 17,232 times

Last updated: Feb 10 '15