Ask Your Question
0

Unable to Login After Customising Xorg Conf to add "TearFree" option for Intel Graphics

asked 2016-09-11 17:08:55 -0600

alza gravatar image

Hi there,

I am running F24 and I'm trying to customise the Xorg configuration to enable the "TearFree" option for my Intel graphics.

Here is the Xorg conf I am using:

20-intel.conf

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "TearFree" "true"
EndSection

I copy this file to the appropriate directory:

sudo cp 20-intel.conf /etc/X11/xorg.conf.d/

However, after doing this, when I try and login to X/Gnome, it immediately returns me back to the login screen.

The Xorg log shows the error "No devices detected" (see below). Removing /etc/X11/xorg.conf.d/20-intel.conf allows me to login again, but then of course the option I'm trying to set won't take effect.

What am I doing wrong?

Thanks :)

Alex.

    X.Org X Server 1.18.4
Release Date: 2016-07-19
[  8829.242] X Protocol Version 11, Revision 0
[  8829.242] Build Operating System:  4.6.4-301.fc24.x86_64 
[  8829.242] Current Operating System: Linux rigel 4.7.2-201.fc24.x86_64 #1 SMP Fri Aug 26 15:58:40 UTC 2016 x86_64
[  8829.242] Kernel command line: BOOT_IMAGE=/vmlinuz-4.7.2-201.fc24.x86_64 root=UUID=63943bad-b12c-464d-b7fe-43db8c07a99f ro rd.luks.uuid=luks-9d15e860-fac7-40d4-8158-5ef29a70ae2a rd.luks.uuid=luks-868b0464-f203-4f41-a05b-921fd56b5c30 rhgb quiet acpi_enforce_resources=lax intel_iommu=on
[  8829.242] Build Date: 25 August 2016  05:27:31PM
[  8829.242] Build ID: xorg-x11-server 1.18.4-4.fc24 
[  8829.242] Current version of pixman: 0.34.0
[  8829.242]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  8829.242] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  8829.242] (==) Log file: "/home/alex/.local/share/xorg/Xorg.0.log", Time: Sun Sep 11 21:28:09 2016
[  8829.242] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  8829.242] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  8829.243] (==) No Layout section.  Using the first Screen section.
[  8829.243] (==) No screen section available. Using defaults.
[  8829.243] (**) |-->Screen "Default Screen Section" (0)
[  8829.243] (**) |   |-->Monitor "<default monitor>"
[  8829.243] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[  8829.243] (**) |   |-->Device "Intel Graphics"
[  8829.243] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[  8829.243] (==) Automatically adding devices
[  8829.243] (==) Automatically enabling devices
[  8829.243] (==) Automatically adding GPU devices
[  8829.243] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  8829.243] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[  8829.243] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  8829.243] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  8829.243] (II) Loader magic: 0x824dc0
[  8829.243] (II) Module ABI versions:
[  8829.243]    X.Org ANSI C Emulation: 0.4
[  8829.243]    X.Org Video Driver: 20.0
[  8829.243]    X.Org XInput driver : 22.1
[  8829.243]    X.Org Server Extension ...
(more)
edit retag flag offensive close merge delete

Comments

Perhaps a driver issue? Try using the same config but remove the "TearFree" option. Otherwise, is your intel chipset supported? Do you need to check the non-free options?

pandita gravatar imagepandita ( 2016-09-12 07:47:18 -0600 )edit

I am having the exact same issue with Fedora 25. I want to enable "TearFree" for intel. Have you been able to figure it out? I can run Xorg :2 -configure like fcomida suggested, I'm getting "Segmentation fault" errors.

kdaker gravatar imagekdaker ( 2016-12-29 13:15:15 -0600 )edit

I have exactly the same problem, Fedora 25, Dell Latitude with Skylake 6th gen. Can' add a configuration file for xorg or I get "no device detected" and "no screen found". But I have a terrible tearing with Cinnamon!! Please help anyone??

Gion86 gravatar imageGion86 ( 2017-03-07 12:29:03 -0600 )edit

OK, I'm using the kernel modesetting driver, and have no tearing. The intel driver is going to be dropped in Fedora 26

http://hansdegoede.livejournal.com/16976.html

so... I feel myself on the bleeding edge :)

Just add

i915.modeset=1

to /etc/default/grub

and then regenerate grub cfg with:

grub2-mkconfig -o /boot/grub2/grub.cfg
Gion86 gravatar imageGion86 ( 2017-03-21 16:35:03 -0600 )edit

And I'm using this cfg file for X, /etc/X11/xorg.conf.d/20-modesetting.conf:

Section "Device"
Identifier  "Intel Graphics"
Driver      "modesetting"
Option      "AccelMethod"    "glamor"
Option      "DRI"            "3"
EndSection
Gion86 gravatar imageGion86 ( 2017-03-21 16:35:47 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-09-12 08:09:08 -0600

fcomida gravatar image

Run Xorg :2 -configure from a virtual terminal as root. It will create a new config file "/root/xorg.conf.new" that you can edit and move to "/etc/X11/xorg.conf"

Strangely enough my intel graphic card has TearFree enabled according to the log even though I don't have any configuration file under "/etc/X11"

edit flag offensive delete link more

Comments

I can't run the Xorg -configure command. With any display number I get a seg fault: this is the org log link text

I'm on Fedora 25, Dell Latitude with Skylake 6th gen, Intel HD Graphics 520 (rev 07)

please help..

Gion86 gravatar imageGion86 ( 2017-03-07 12:33:20 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2016-09-11 17:08:55 -0600

Seen: 1,579 times

Last updated: Sep 12 '16