Ask Your Question
0

fedora 16 compiler

asked 2011-11-20 22:46:26 -0600

oddasee gravatar image

updated 2011-11-25 22:20:32 -0600

mether gravatar image

I'm using fedora 16-64 but my desktop locks up whenever I compile with g++. The compile also takes much longer depending on how bad the freeze. The desktop becomes unusuable until the compile (finally) stops. I have compiz running.

Any ideas?

Thanks

Also firefox complains of bad scripts during these lockouts.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-21 03:29:10 -0600

lzap gravatar image

The question is what do you compile. Some projects are really huge and it can be pain to compile them. Then the question can be how do you compile it. You should be able to turn off parallel compilation for example. Depends on the project how to do it.

Try to run it "on the background" (works on Fedora 16 and modern distros):

nice -n 19 ionice -c2 -n7 your_command_here
edit flag offensive delete link more
0

answered 2011-11-21 00:54:18 -0600

oddasee gravatar image

The memory use is quite high - typically 800 MB ( out of 1 Gb ) and 500 MB swap, running nothing other than firefox and COMPIZ... Using the compiler causes a jump from 73% to 83% in memory usage and no increase in swap. In prior operating systems I am more accustomed to using LESS than 50% RAM and less than 300 MB swap in typical use.

It looks to me like the CPU is not scheduling correctly since the memory usage, although high, suggests there is room for additional tasks.

edit flag offensive delete link more
0

answered 2011-11-20 23:13:39 -0600

asto gravatar image

Sounds like you're running out of RAM and swapping to disk

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-20 22:46:26 -0600

Seen: 338 times

Last updated: Nov 21 '11