Ask Your Question
0

Fedora 24 hibernation error: Sleep verb not supported

asked 2016-09-07 14:23:26 -0600

DasOhmoff gravatar image

Hi, when I type:

systemctl hibernate

into the terminal, the out is:

Failed to hibernate system via logind: Sleep verb not supported

How to fix this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-05 09:03:00 -0600

mikmik gravatar image

In Fedora 24 (and I believe it is from Fedora 22 up) the hibernate or hybrid sleep is not enabled by default. To enable it run this code as root:

#!/bin/bash
# Enable hibernation
# Using info from:
# https://psohny.wordpress.com/2015/08/13/fedora_hiber/

# Enable recovery in the /etc/default/grub
sed -i -e 's|^\(GRUB_DISABLE_RECOVERY="\)true"|\1false"|' /etc/default/grub

#Find the swapdevice
SWAPDEVICE=`grep -e '^[^#].*swap' /etc/fstab | head -n 1 | cut -d ' ' -f 1`
echo "Using SWAPDEVICE=${SWAPDEVICE} for hibernation"

#add "resume=swapdevice" to the GRUB_CMDLINE_LINUX=
sed -i -e "s|^\(GRUB_CMDLINE_LINUX=\".*\)\"|\1 resume=${SWAPDEVICE}\"|" /etc/default/grub

#Regenerate the grub config
/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg

After regenerating the grub configuration, now you need to reboot your machine

reboot

Now after reboot it will be possible to hibernate or even hybrid-sleep

systemctl hibernate -i
systemctl hybrid-sleep -i
edit flag offensive delete link more

Comments

Ty so much, I had this problem with Ubuntu 16.04 and this fixed it!

gg gravatar imagegg ( 2017-09-11 00:59:00 -0600 )edit
0

answered 2016-09-07 18:48:23 -0600

richard kus gravatar image

did you follow the common F24 bugs FedoraProjects about hibernation

edit flag offensive delete link more

Comments

I did. And also first step from here (not sure if necessary). After reboot 'systemctl hibernate' works.

freetomik gravatar imagefreetomik ( 2016-09-08 14:11:54 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-07 14:22:57 -0600

Seen: 6,595 times

Last updated: Sep 07 '16