Ask Your Question
0

No 3D Acceleration - F16, Catalyst 12.1, HD4850

asked 2012-02-28 23:32:25 -0500

BinaryMage gravatar image

updated 2012-02-28 23:40:40 -0500

Forgive me if this is a silly question. I'm new to Fedora (not to Linux) and I'm having an issue with video drivers. Installed Fedora 16 x86 on my HD 4850; default driver worked fine. Installed Catalyst 12.1 (for dual-display, OpenCL, and better 3D), upon reboot GNOME 3 starts in fallback mode & 3D acceleration doesn't work (see below).

dmesg gives nothing of use.

lspci | grep ATI gives

01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio

glxgears gives:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  138 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

cat /var/log/Xorg.0.log | grep fglrx gives:

http://fpaste.org/yww6/ (too long to post)

I have no clue what that means, but it seems 3D acceleration is not working properly. Googling didn't pull up any answers, so if you would be gracious enough to enlighten me as to how to get GNOME 3 working again, it would be much appreciated!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-03-06 08:14:26 -0500

mether gravatar image

Questions on the proprietary drivers are probably better being redirected to the vendor forums.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-28 23:32:25 -0500

Seen: 1,289 times

Last updated: Mar 06 '12