Ask Your Question
2

Browsing and dnf issues in f24, f25 and f26 in Ecuador. Is it about Mirrors, ipv6?

asked 2016-08-19 11:56:16 -0600

christianbueno gravatar image

updated 2017-11-21 14:17:07 -0600

country: Ecuador
city: Guayaquil
Internet services plan: 5Mbps down/ 1Mbps up, download average 500KiB/s
mirror, Ecuador EC:
image description


 peter  ~  cat /etc/dnf/dnf.conf 
[main]
gpgcheck=1
installonlylimit=3
cleanrequirementsonremove=True

Now I am in f26, first ,thanks for your awesome work in f26 , is very apreciate , i like fedora , thanks team fedora and all the people behind this project.
In f24 it was slow in the sense that it took longer to load webpages. Similar issues in f25.
Is the network or download process in fedora different than others distro like ubuntu 15.10 , antergos(archlinux) or windows 10 since they works fine either by browsing or by terminal?
Is it about mirrors?, because ubuntu has two, one in my city the other far away and it is the same that has fedora , and arch has three and one is the same too that has fedora.

ubuntu mirrors
image description

Arch mirrors
image description

browsing issues in f26
image description
image description
image description
image description


Terminal issues in f26
image description

You are doing a very good os, It would be great to know more about this issues so that we could deal with these. thanks

edit retag flag offensive close merge delete

Comments

Hello , firefox is very different in fedora 25 you can notice the difference, is very fast

christianbueno gravatar imagechristianbueno ( 2016-11-23 07:17:52 -0600 )edit

Are you using fast mirror? then you need disable it...

davidva gravatar imagedavidva ( 2017-07-19 03:17:05 -0600 )edit

/etc/dnf/dnf.conf with fastestmirror=1 ?

sergiomb gravatar imagesergiomb ( 2017-07-19 06:51:00 -0600 )edit

yes I tested fastestmirror=1 in the past , it doesn't fix the problem

christianbueno gravatar imagechristianbueno ( 2017-07-19 08:41:29 -0600 )edit

I got a notification that the question was edited, but I can't tell what was changed. Did you try my suggestion about disabling IPv6 or was this completely solved by the NVidia drivers? Which would be a very strange solution to a network issue.

ssieb gravatar imagessieb ( 2017-07-27 18:09:56 -0600 )edit

10 Answers

Sort by » oldest newest most voted
1

answered 2017-07-19 14:02:48 -0600

ssieb gravatar image

It looks like you are using IPV6 and I wonder if there is a problem with your ISP for that. In your network connection settings, disable IPV6 and then reconnect. See if that works better.

edit flag offensive delete link more

Comments

who is the responsable of maintain ipv6 ?

  • ISP
  • Operating System
christianbueno gravatar imagechristianbueno ( 2017-11-21 14:22:00 -0600 )edit

Both of those in some way as well as your router if you aren't directly connected to your internet cable or DSL box (or whatever you use). Try disabling IPv6 in your network connection and see if that solves the problem.

ssieb gravatar imagessieb ( 2017-12-01 17:11:24 -0600 )edit

Thanks pal, I disable IPV6 on my modem (ADSL+Wi-Fi Router).

christianbueno gravatar imagechristianbueno ( 2018-05-09 22:47:54 -0600 )edit
2

answered 2016-08-19 18:05:11 -0600

ssieb gravatar image

I haven't used Ubuntu, so I can't compare. But you could. In the Firefox menus, go to Tools->Web Developer->Network. Reload the page and it will show you how long all the parts of the page took to load. You can do that on both Ubuntu and Fedora and compare the results. However, for it to be a useful comparison, it needs to be on similar computers on the same network at a similar time of day. And watch out for caching effects.

edit flag offensive delete link more

Comments

important information, thank you

christianbueno gravatar imagechristianbueno ( 2016-08-20 13:28:04 -0600 )edit
0

answered 2017-11-20 01:01:40 -0600

davidva gravatar image

??? you can disable ipv6 in your connection... a simple example:

image description

image description

edit flag offensive delete link more
0

answered 2016-10-19 06:06:02 -0600

fedoj0 gravatar image

im not sure if this will help EVERYONE, but this resolved my issue.

found here: https://ask.fedoraproject.org/en/ques... user Zdenech posted a resolution to fixing slow download performance in steam, this also fixed my issue with firefox dragging so bad.

  1. Disable dnsmasq service

sudo systemctl stop dnsmasq.service

  1. Then edit /etc/NetworkManager/NetworkManager.conf file - add (or modify if already defined) following line under section [main]

dns=dnsmasq

  1. Now restart NetworkManager

sudo systemctl restart NetworkManager.service

NetworkManager will automatically start dnsmasq.

  1. Add 127.0.0.1 to /etc/resolv.conf.
edit flag offensive delete link more
0

answered 2016-08-27 14:17:23 -0600

sergiomb gravatar image

May be is the kernel and tcp security problem , I still use kernel-4.5.7-202.fc23.x86_64 , kernel 4.6 and 4.7.1 I still see big slowdowns in firefox and in all system .

edit flag offensive delete link more
0

answered 2016-12-27 07:46:14 -0600

rhandwor52 gravatar image

Try dnf install seamonkey I also have a Opera web browser. Google Fedora 25 Opera rpm file.

edit flag offensive delete link more
0

answered 2016-08-20 14:14:33 -0600

David-LDA gravatar image

It seemed much faster on Fedora 24 than on Windows 10 on the same machine at the weekend... if that's any help.

edit flag offensive delete link more
0

answered 2016-08-20 18:11:57 -0600

baitillus gravatar image

My brother has ubuntu installed on a computer much more powerfull than mine and firefox goes lightning fast on my humble satellite s50-b with fedora 24 compared with he's asus beast. Ubuntu has better driver support though :/

edit flag offensive delete link more
0

answered 2017-11-19 21:40:59 -0600

christianbueno gravatar image

hello pals, the problems finally seems to be ipv6 , always have to disable ipv6 first when turn on the pc , i run in terminal

as root
# echo "1" > /proc/sys/net/ipv6/conf/all/disable_ipv6

If you don't want to run this command, you can use always the -4 option, i.e.

sudo dnf install vim-enhanced -4
sudo dnf update -4

In firefox you must disable ipv6 too, in the url bar type about:config , then type network.dns.disableIPv6 and change value to TRUE.
Is there a best way to disbale ipv6 or another way to avoid ipv6 problems ?

edit flag offensive delete link more

Comments

Is my ISP giving me a bad ipv6 services? @davidva @"Samuel Sieb" how find a solution for a better ipv6 perfomance

christianbueno gravatar imagechristianbueno ( 2017-11-21 14:30:42 -0600 )edit

I missed this comment. Many ISPs don't really support IPv6 even though it's "available". If it's not working for you, just disable it as another poster has given you instructions for. Then you don't need to disable it every reboot.

ssieb gravatar imagessieb ( 2017-12-01 17:15:38 -0600 )edit

Yes , I disabled IPV6 on my Modem (ADSL+Wi-Fi Router) and don't have to worry about IPV6 anywhere else.

christianbueno gravatar imagechristianbueno ( 2018-05-09 22:53:50 -0600 )edit
0

answered 2016-08-27 11:59:22 -0600

devnull gravatar image

Firefox is a slow resource sucking PIG! It works no better on F24 than it did on WinXP years ago. I am currently looking for another browser. I have an nvidia graphix card, and everything else with display seems OK for now; I don't want to risk installing nvidia drivers - my experience is the worst things happen most frequently when messing with video drivers ...

edit flag offensive delete link more

Comments

1

As of August 2016 Chromium is now in the official Fedora repo! https://fedoraproject.org/wiki/Chromium

It does seem faster than Firefox, but I still prefer Firefox! Hope they speed Firefox up.... not that it's that slow.

David-LDA gravatar imageDavid-LDA ( 2016-08-29 12:41:01 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-08-19 11:56:16 -0600

Seen: 1,819 times

Last updated: Nov 21 '17