Ask Your Question
3

Why doesn't my Backspace key work in Firefox?

asked 2016-08-16 18:01:29 -0600

First-time Fedora user, first hour of use. Running Fedora-Workstation-live-x86_24-1.2 from DVD (ISO & DVD burn both verified). Not yet installed to HDD, No change to default GUI options. Thinkpad T420.

I'm used to Firefox letting me go back to the previous webpage in the current tab's history, as in many other browsers also, by simply pressing the Backspace key. However, that isn't working in Firefox right now. Nothing coming up on a web search for this issue that I see.

Is this more likely to be a hardware issue, a live boot issue (resolved by full HDD install of Fedora), or some other issue? Thanks for any suggestions/resources, in advance.

edit retag flag offensive close merge delete

Comments

Thanks, that will work for now. Can you convert your comment to an answer so I can mark this question closed with answer? :)

mysticalsister gravatar imagemysticalsister ( 2016-08-16 19:02:49 -0600 )edit
1

Please, don't close any answers - just mark them as correct (by ticking the check mark) if they are so. Cheers!

florian gravatar imageflorian ( 2016-08-16 21:41:46 -0600 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2016-08-17 03:12:23 -0600

jake gravatar image

To enable backspace to "go back" do the following:

Open Firefox and enter "about:config" in the address bar. A warning from Firefox will be displayed, just promise to be careful. In here search for "browser:backspace_action", double click on it and change its value from 0 to 2.

That’s it. Now if you hit backspace, it will take you to previous webpage.

Hope this helpful, greets jake

edit flag offensive delete link more

Comments

Jake, thank you for the more literal answer to my question. I'm happy to use other shortcuts, as long as it's a single key that I can consistently use across diff distros. The Thinkpad backpage & forwardpage buttons work better for me, but your answer is helpful/"correct" also - wish I could mark two answers as good solutions!

mysticalsister gravatar imagemysticalsister ( 2016-08-17 03:47:09 -0600 )edit

In FF 61 it's the other way around: change 2 to 0. It's set to 2 by default. Changed it just now and finally have my backspace. :) Thank you for the direction!

verlioca gravatar imageverlioca ( 2018-08-01 23:14:19 -0600 )edit
1

answered 2016-08-16 20:29:17 -0600

florian gravatar image

updated 2016-08-16 21:40:22 -0600

Shortcuts are:

  • page back: ALT +LEFT ARROW
  • page forward: ALT +RIGHT ARROW

On some Thinkpads you can also use the two dedicated keys next to the arrow keys to navigate forward/backwards.

edit flag offensive delete link more

Comments

Thanks! Is there a way I can view the text formatting syntax you used for that post? If it's wiki formatting, I'll go look it up for myself, or if I know what form of markdown it is, I'll go research that. :) Thanks!

mysticalsister gravatar imagemysticalsister ( 2016-08-16 22:46:07 -0600 )edit
2

The text formatting is part of this site. To mark something as Code, all you need to do is highlight it and click on the icon at the top of the text entry box that has the 101 and 010 in it, the fourth from the left. If you do it to one or more lines

This is what it looks like.

Feel free to experiment because you can always edit your comment if it doesn't come out the way you want.

sideburns gravatar imagesideburns ( 2016-08-17 01:40:05 -0600 )edit

I took a screenshot for you, while in editing mode: See here: http://imgur.com/a/4DDv6

More info on formatting in askbot here: https://sourceforge.net/p/askbot/wiki...

florian gravatar imageflorian ( 2016-08-17 10:50:40 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-08-16 18:01:29 -0600

Seen: 994 times

Last updated: Aug 17 '16