Ask Your Question
3

Why does gnome-terminal crash? Is my locale OK?

asked 2016-08-08 13:16:31 -0600

markito3 gravatar image

updated 2016-08-09 12:43:44 -0600

My gnome terminal does not come up. Worked before I upgraded to Fedora 24. The error message is

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

Seems like I've been down his road before but can't find anything in my notes. Something about locale perhaps?

edit retag flag offensive close merge delete

Comments

What is the output of localectl as your user, not root?

ssieb gravatar imagessieb ( 2016-08-08 13:33:49 -0600 )edit
$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: us
      X11 Layout: us
markito3 gravatar imagemarkito3 ( 2016-08-08 17:56:26 -0600 )edit

Was there anything before that error message you pasted in the question? Where are you trying to run it from since you don't have a Gnome terminal?

ssieb gravatar imagessieb ( 2016-08-09 16:54:14 -0600 )edit

Good question! I ran the command in an xterm.

markito3 gravatar imagemarkito3 ( 2016-08-09 18:03:41 -0600 )edit
1

Every reference to this kind of issue that I've seen involves the locale info.

What are the outputs of locale and locale -a? If the second one has a large of amount of output, then don't include it.

Also rpm -qa | grep glibc.

ssieb gravatar imagessieb ( 2016-08-09 18:36:23 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2016-09-10 08:36:14 -0600

markito3 gravatar image

updated 2016-09-10 08:38:05 -0600

Here is more info on the problem. It appears not to have a solution that is fixable given my skill set.

The "wrong" locale appears when gnome-terminal does not see an instance of gnome-terminal-server. Rather than starting one itself, it sends a signal to the dbus to start one. The rogue local is then introduced when that signal is serviced. Not clear how to influence that environment. [Ref. #2]

Here is my interpretation. The gnome-terminal site says something like "ask your distribution how to fix its locale". [Ref. #1] The distribution is saying, it is not our responsibility to ensure a proper locale for gnome-terminal, why should gnome terminal be the one deciding what is proper for everyone? I. e., UTF-8 or the highway. We won't fix it. [Ref. #3] So there is a standoff.

This leaves me with a gnome-terminal that is dead broken when using gnome shell under Fedora 24. Kind of non-optimal, IMHO. ;-)

edit flag offensive delete link more

Comments

I'm mystified as to where gnome-terminal-server is getting the locale from. And why it only seems to happen to very few people. Btw, you didn't provide the information I asked for in the earlier comment.

ssieb gravatar imagessieb ( 2016-09-16 17:16:43 -0600 )edit

This problem seems to have disappeared once I upgraded to Fedora 25. Go figure!

markito3 gravatar imagemarkito3 ( 2016-11-27 20:33:01 -0600 )edit

Problem is back. Still with Fedora 25.

markito3 gravatar imagemarkito3 ( 2017-03-08 13:32:03 -0600 )edit
1

answered 2018-05-29 14:19:31 -0600

davidcl gravatar image

My 2cents for people having similar issues after upgrading from f27 to f28. Your system might need some extra glibc-langpack to start correctly. For example, I configured my system to be fr_FR.utf8 and after upgrading, I had to install manually glibc-langpack-fr to have a working gnome-terminal.

edit flag offensive delete link more

Comments

Thanks, I had the same issue and this fixed it. dnf install glibc-langpack-fi in my case

varesa gravatar imagevaresa ( 2018-06-07 06:44:41 -0600 )edit
0

answered 2016-10-04 20:30:18 -0600

florian gravatar image

updated 2016-10-04 20:45:45 -0600

Experienced the same problem with gnome-terminal, and here is the simple step that fixed my problem:

localectl showed that System Locale was not set (I don't know the reason though):

System Locale: n/a
VC Keymap: us
X11 Layout: us
X11 Options: grp:win_space_toggle

Setting it, followed by a reboot fixed it. To do so, execute:

localectl set-locale LANG=en_US.utf8 (Of course, you may want to adapt the locale to what you need/want and what is available on your system (locale -a).

All commands should be run as your regular user, not root.

edit flag offensive delete link more
0

answered 2016-08-10 13:34:26 -0600

robbiethek gravatar image

I'm having the same problem here's mine:

# locale 
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[root@linux-user-101 ~]# rpm -qa | grep glibc
glibc-2.23.1-8.fc24.i686
glibc-common-2.23.1-8.fc24.x86_64
glibc-devel-2.23.1-8.fc24.x86_64
glibc-all-langpacks-2.23.1-8.fc24.x86_64
glibc-headers-2.23.1-8.fc24.x86_64
glibc-2.23.1-8.fc24.x86_64

as well as logs in /var/log/messages:

Aug 10 14:13:17 linux-user-101 org.gnome.Terminal.desktop: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached
Aug 10 14:13:28 linux-user-101 org.gnome.Shell.desktop: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Nautilus.desktop: Gio.IOErrorEnum: Timeout was reached
Aug 10 14:13:28 linux-user-101 org.gnome.Shell.desktop: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Terminal.desktop: Gio.IOErrorEnum: Timeout was reached
Aug 10 14:13:28 linux-user-101 dbus[809]: [system] Failed to activate service 'org.bluez': timed out
Aug 10 14:13:35 linux-user-101 org.gnome.Terminal.desktop: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached
edit flag offensive delete link more

Comments

You ran the command as root. Try running locale as your user.

In your case, it looks like you have a general dbus issue. I see timeouts for several different services there.

ssieb gravatar imagessieb ( 2016-08-11 18:40:11 -0600 )edit

You are right, I never did try those suggestions. Don't know why...

But now I have:

For reference, original /etc/locale.conf:

LANG="en_US.UTF-8"

After executing "localectl set-locale LANG=en_US.utf8" as root, locale.conf is

LANG=en_US.utf8

After "localectl set-locale LANG=en_US.UTF-8"

LANG=en_US.UTF-8

markito3 gravatar imagemarkito3 ( 2016-09-17 18:25:54 -0600 )edit

Question Tools

3 followers

Stats

Asked: 2016-08-08 13:16:31 -0600

Seen: 7,285 times

Last updated: Oct 04 '16