Ask Your Question
4

Auto running two commands at boot

asked 2013-01-20 23:09:20 -0600

ioncube gravatar image

updated 2013-06-23 06:02:44 -0600

FranciscoD_ gravatar image

Thanks to this community & fedorforums that I was able to install Broadcom STA drivers on my Dell Vostro. Now the problem is that at every startup I have to run tWo commands (AS ROOT) to actually load wireless module. These are:

rmmod ssb
modprobe wl

I know, I know I have tried blacklisting ssb module (for wl to work properly) but even Broadcom documentation states that sometimes it won't; so any alternatives here? I already have tried doing

echo rmmod ssb >> /etc/rc.local  
echo modprobe wl >> /etc/rc.local

Have also tried such with this location /etc/rc.d/rc.local

edit retag flag offensive close merge delete

Comments

I have a Dell Vostro also, and my wireless card works well with the free driver that comes with the kernel. Your card doesn't work with the free driver??

skytux gravatar imageskytux ( 2013-01-21 06:22:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
7

answered 2013-01-25 07:58:08 -0600

Peter Scott gravatar image

updated 2013-02-08 08:54:49 -0600

/etc/rc.d/rc.local is the place for the commands but you have to ensure the rc-local service is enabled and running.

If you have a /etc/rc.d/rc.local before you upgrade to F18, fedup will enable the service. If you do not have one, getting F18 to start the service can be done as root:

# systemctl start rc-local
# systemctl status rc-local
rc-local.service - /etc/rc.d/rc.local Compatibility
          Loaded: loaded (/usr/lib/systemd/system/rc-local.service; static)
          Active: active (exited) since Fri 2013-01-25 13:33:28 GMT; 9min ago

Jan 25 13:33:27 peters.localdomain systemd[1]: Starting /etc/rc.d/rc.local C....
Jan 25 13:33:28 peters.localdomain systemd[1]: Started /etc/rc.d/rc.local Co....
Jan 25 13:42:35 peters.localdomain systemd[1]: Started /etc/rc.d/rc.local Co....
#

Here is a "hello world" /etc/rc.d/rc.local:

#!/bin/sh
set &>> /home/ioncube/debug
exit 0

It shows the environment in which the script runs. (You might need full path names on the commands your final versions of /etc/rc.d/rc.local calls.)

Postscript @randomuser: I thought enable was needed too but it gave an error:

# systemctl enable rc-local.service
The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
#

BTW: system-config-services would not start the service. This might be because it reacted wrongly to the error message when I tried to enable the service.

Postscript @kynde: I don't think the link makes any difference. I have two f18s, one with the link and one without; they both run my rc.local.

edit flag offensive delete link more

Comments

1

+1, but shouldn't you enable rc-local.service ?

randomuser gravatar imagerandomuser ( 2013-02-03 00:12:30 -0600 )edit

thanks this was useful. For anyone else who reads this - I got the same error as ioncube - I fixed it by adding 'exit 0' to the end of rc.local file.

ian6040 gravatar imageian6040 ( 2014-05-19 11:46:35 -0600 )edit

@kynde solution works.

Ion Dulgheru gravatar imageIon Dulgheru ( 2014-12-02 13:25:10 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-01-20 23:09:20 -0600

Seen: 24,585 times

Last updated: Dec 02 '14