Ask Your Question

Fedora 24: Kernel 4.6, Asus Zenbook pro UX501VW CPU/GPU Fan runs continuously on high speed.

asked 2016-08-03 12:14:58 -0600

greatlinux gravatar image

updated 2016-08-03 14:06:04 -0600

Hi All,

I am newbie to the forum. Recently I bought Asus Zenbook Pro and tried installing fedora 24 on it which resulted in laptop's CPU fan starts at boot and runs continuously at very high speed. Details are as follows-

H/w Detail- - Skylake 6700HQ - NVIDIA 960M

Installation Details and issue- FC24+Kernel 4.6 1. Doesn't boot in GNOME, had to boot in wayland. 2. Fan starts at boot and runs continuously. 3. Doesn't detect Intel and NVIDIA graphics cards.

Tried Following and faced issues- 1. FC24+ Kernel 4.5 //Same Fan runnning issues 2. FC23+ Kernel 4.5 //Same Fan runnning issues 3. FC23+ Kernel 4.2 //Elantech Trackpad not detected.

Please help me with the fix or temporary work around out there. Thanks a lot.

edit retag flag offensive close merge delete


Added More details.

greatlinux gravatar imagegreatlinux ( 2016-08-03 14:06:41 -0600 )edit

Fedora do not include Nvidia proprietary kernel modules only Noveau, you can add Nvidia kernel modules from rpmfusion installing akmod-nvidia and kernel-devels. Also do your pc has two video cards if so you need to disable the other one. Google rpmfusion nvidia and you will find instructions to install properly. The fan issues will probably has to do with your bios you need to look into manufacture site to look for bios driver for Linux.

aeperezt gravatar imageaeperezt ( 2016-08-03 14:29:22 -0600 )edit

I already have upgraded and latest bios from ASUS, Not sure if they gonna upgrade in near future. Any other work around ? Just to add Kernel 4.2 doesn't have Fan issue but the latest have this.

greatlinux gravatar imagegreatlinux ( 2016-08-03 16:53:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-08-03 18:17:28 -0600

sixpack13 gravatar image

updated 2016-08-03 18:29:06 -0600

to Elantech Trackpad:

in the bios of my acer notebook I have to switch setting regarding touchpad to "Basic" or something like that.

graphic's: I found some boot param's here:

maybe they help a bit ...

edit flag offensive delete link more

Question Tools


Asked: 2016-08-03 12:14:58 -0600

Seen: 595 times

Last updated: Aug 03 '16