Ask Your Question
2

After updating Fedora23 to 24 my Windows/UEFI does not start.

asked 2016-07-31 13:46:24 -0500

Siebert gravatar image

I successfully updated my Fedora 23 to version 24. However, the Windows (UEFI dual boot) system, which did work before, does not boot anymore: although the grub menu appears, only a black screen appears when Windows is selected.

In your documentation I noticed that this is already a known bug. It suggest to use the UEFI boot menu and/or to downgrade grub. With the first of these options, I can successfully start windows again. Now I'd like to downgrade grub as suggested to grub2-2.02-0.25.fc23 (grub2 from Fedora 23). I already tried various thinks such as "dnf install grub2-2.02-0.25.fc23" or "dnf downgrade grub2-2.02-0.25.fc23" but unfortunately nothing works. I'm new to dnf so please forgive my stupidity. What exactly needs to be done to get a working version of grub again? Many thanks in advance.

edit retag flag offensive close merge delete

Comments

Hi @Siebert, where did you find the description of the bug? bugzilla? I am interested because it looks like I am facing the same/similar problem dualbooting F24 and Win7

gobigobi66 gravatar imagegobigobi66 ( 2016-08-01 11:24:15 -0500 )edit

This bug and the above workarounds are described on FedoraProject.org . Here is the complete link: https://fedoraproject.org/wiki/Common...

Siebert gravatar imageSiebert ( 2016-08-01 12:11:05 -0500 )edit

I had the opposite problem a few days back. Updated to Windows 10 Anniversary Edition, and it removed everything but Windows from my EFI partition. So the problems go both ways.

Aeyoun gravatar imageAeyoun ( 2016-08-06 19:49:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-08-04 09:24:21 -0500

Siebert gravatar image

The solution suggested by cmurf was what I was looking for - for me it works perfectly! Here are the detailed commands for my x86-64 system to solve the problem:

$ rpm -qa | grep grub2
grub2-efi-2.02-0.34.fc24.x86_64
grub2-tools-2.02-0.34.fc24.x86_64
grub2-2.02-0.34.fc24.x86_64
$ mkdir downgrade_grub
$ cd downgrade_grub
$ GRUBSOURCE=https://kojipkgs.fedoraproject.org//packages/grub2/2.02/0.24.fc23/x86_64
$ wget $GRUBSOURCE/grub2-efi-2.02-0.24.fc23.x86_64.rpm
$ wget $GRUBSOURCE/grub2-tools-2.02-0.24.fc23.x86_64.rpm
$ wget $GRUBSOURCE/grub2-2.02-0.24.fc23.x86_64.rpm
$ sudo dnf downgrade *rpm

Thank you all for your answers!

edit flag offensive delete link more
0

answered 2016-08-01 22:36:33 -0500

I had the same problem with one machine.
The solution was:

# dnf install grub2-efi-modules
# grub2-install /dev/sda

Note: Probably the problem was caused during the upgrade process.
The package grub2-efi-modules was not installed causing the command 'grub2-install' to fail, leaving the old grub2 boot loader.

edit flag offensive delete link more

Comments

FYI, grub2-install is not recommended on UEFI machines because it replaces the grubx64.efi OS Loader that's signed by the Fedora Project, and is in the grub2-efi package. Dual boot does not require anything found in grub2-efi-modules package either.

For the OP you need to downgrade all the related grub2 packages on the system, so 'rpm -qa | grep grub2' to see that list of packages, find and download their older equivalents in koji into their own directory, cd to that, and then 'dnf downgrade *rpm' should do what you want.

cmurf gravatar imagecmurf ( 2016-08-02 18:33:54 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-31 13:46:24 -0500

Seen: 716 times

Last updated: Aug 04 '16