Ask Your Question
0

Fedora 16 repeat key issue

asked 2011-11-27 03:17:16 -0500

Ramkumar gravatar image

Hi I have installed Fedora 16 and I have a problem with typing in any application. If the letlers come continously, i am getting a warning sound and the letter is not getting typed. For eg, if I try to type ball, i am able to type bal, the moment I type the second l, I get a warning sound and second l is not getting typed. Same thing happens with backspace.

Can anyone help me in solving this issue.

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
0

answered 2011-12-15 08:32:26 -0500

trojanfoe gravatar image

updated 2011-12-15 08:42:51 -0500

I also have this issue and I can only seem to resolve it by using the keyboard setting application (type 'keyboard' into the Application search box under Gnome 3).

I have tried writing a script to use gconftool-2 to reset the values but it doesn't make any difference:

#!/bin/sh

gconftool-2 --set /desktop/gnome/peripherals/keyboard/repeat --type bool false
gconftool-2 --set /desktop/gnome/peripherals/keyboard/rate --type int 30
gconftool-2 --set /desktop/gnome/peripherals/keyboard/delay --type int 500
gconftool-2 --set /desktop/gnome/peripherals/keyboard/repeat --type bool true

EDIT: Actually your problem sounds like it might be 'Bounce Keys' being on (see the accessibility icon in the top-right).

edit flag offensive delete link more
0

answered 2012-04-01 21:33:49 -0500

The problem is , at least for me, "bounce keys". It is a setting under universal access.

Turn bounce Keys off

Bounce keys

edit flag offensive delete link more
0

answered 2011-11-27 04:08:11 -0500

lzap gravatar image

Check your BIOS settings for keyboard repetition delay. Or do you have a different OS to test against?

edit flag offensive delete link more
0

answered 2011-11-28 23:32:59 -0500

FranciscoD_ gravatar image

In GNOME, check the keyboard settings. There's an option to set key repeat delay iirc.

edit flag offensive delete link more
0

answered 2011-11-27 04:54:44 -0500

Ramkumar gravatar image

yes I have windows 7 and it works fine in it

edit flag offensive delete link more
0

answered 2012-04-23 06:50:18 -0500

steeve gravatar image

Turning off bounce keys worked for me. Thank dog, that was driving me nuts whenever logging in.

I wonder if the Accessibility Icon can be removed from the gdm screen so my kids won't enable it again?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-27 03:17:16 -0500

Seen: 1,525 times

Last updated: Apr 23 '12