Ask Your Question
1

How to add the program to "View All Applications" list?

asked 2016-07-25 09:11:11 -0600

wolfv gravatar image

updated 2016-07-29 22:52:40 -0600

I installed a program named "SOLVESPACE" that is not in the DNF package manager. The SOLVESPACE program is not listed under:

Navigator > right click file > Open With Other Application > View All Applications

I added a solvespace.desktop file as described in https://developer.gnome.org/integrati...

$ pwd
/usr/share/applications
$ more solvespace.desktop
[Desktop Entry]
Name=SOLVESPACE
Exec=/usr/local/bin/solvespace
Icon=/home/wolfv/Documents/developer/cad/solvespace/src/icons/in3d.png
Type=Application
Categories=GTK;GNOME;Graphics;
MimeType=application/x-slvs;
Comment=A parametric CAD program

Which caused a second launcher to appear in the "Applications" drop-down menu, and they both work:

Applications > Graphics > SOLVESPACE
Applications > Graphics > SOLVESPACE

I tried the mime file posted by Samuel Sieb, but it didn't help:

$ xdg-mime install slvs.xml
xdg-mime: filename 'slvs.xml' does not have a proper vendor prefix
A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
with a dash ("-"). An example filename is 'example-slvs.xml'
Use --novendor to override or 'xdg-mime --manual' for additional info.
$ mv slvs.xml solvespace-slvs.xml
$ xdg-mime install solvespaslvs.xml
$ mv solvespace-slvs.xml slvs.xml
$ xdg-mime install --novendor slvs.xml
$

From Nautilus > base.slvs > Properties > Basic

Name: base.slvs
Type: Solvespace file (application/x-slvs)

The top of the "Select Application" dialog box says:

Opening "Solvespace file" files

Link to "Select Application" screenshot.

When I click on base.slvs, a popup says:

Could not display "base.slvs".
There is no application installed for "Solvespace file" files.
Do you want to search for an application to open this file?
    No      Yes

Link to pop up screenshot.

$ pwd
/home/wolfv/Documents/developer/cad/solvespace_files/tut_2_assembly
$ ls
base.slvs  box.slvs  divider.slvs  side.slvs
$ xdg-mime query filetype base.slvs 
application/x-slvs

This launches the SOLVESPACE program:

$ /usr/local/bin/solvespace

solvespace properties are:

$ ls -l /usr/local/bin/solvespace
-rwxr-xr-x. 1 root root 7414752 Jul 24 19:43 /usr/local/bin/solvespace

$ file /usr/local/bin/solvespace
/usr/local/bin/solvespace: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=604c120dd076129657719b9ceec579490dcacd49, not stripped

I clicked on solvespace.desktop and SolveSpace launched. Then, in the solvespace.desktop, I changed

Exec=/usr/local/bin/solvespace

to

Exec=/usr/bin/gedit

I clicked on solvespace.desktop again and gedit launched. But neither SolveSpace nor gedit are listed in "Select Application".

How to add the program to "View All Applications" list?

I am running Gnome 3.20 on Fedora 24.

Thank you.

edit retag flag offensive close merge delete

Comments

You can install "nautilus-actions"

davidva gravatar imagedavidva ( 2016-07-25 20:51:54 -0600 )edit

somefile.slvs was supposed to be replaced by an actual existing filename. Nautilus recognizes the mime type, but you still haven't added the MimeType line to the .desktop file.

ssieb gravatar imagessieb ( 2016-07-26 13:24:44 -0600 )edit

@Samuel Sieb, I added MimeType line to solvespace.desktop. But SOLVESPACE is still not listed under "Select Application". I apologize for not adding MimeType to the .desktop file sooner. "update 3" is in the question.

wolfv gravatar imagewolfv ( 2016-07-26 17:19:26 -0600 )edit

You should delete a bunch of the information in the question to make it clearer what the current state is. It worked for me (using a different application). The only thing I can think of is that it doesn't like the executable for some reason. What is the output of file /usr/local/bin/solvespace and ls -l /usr/local/bin/solvespace? From the Gnome overview screen, can you see the solvespace entry?

ssieb gravatar imagessieb ( 2016-07-26 18:19:50 -0600 )edit

@Samuel Sieb, I cleaned up the question, and added your requested output to the end of the question.

Not sure what you mean by "Gnome overview screen". From the top left corner of my screen, there is a "Applications" drop-down menu. It contains two entries of "SOLVESPACE", and they both launch SOLVESPACE.

wolfv gravatar imagewolfv ( 2016-07-26 20:24:04 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-25 14:15:50 -0600

ssieb gravatar image

updated 2016-08-09 17:06:05 -0600

If the application provides a .desktop file, then put it in one of those directories depending on whether it's just for you or other users. If there is no .desktop file, then you will need to create your own. It's quite easy, you can look at the existing ones for an example. Most of the lines are optional and you won't need the translations. Include the line MimeType=application/x-solvespace;

Create an solvespace.xml file containing:

<?xml version="1.0"?>
<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
  <mime-type type="application/x-solvespace">
    <comment>Solvespace file</comment>
    <glob pattern="*.slvs"/>
  </mime-type>
</mime-info>

Then run xdg-mime install --novendor solvespace.xml.

To setup the icon, get a png or svg file. I used the 48x48 icon from solvespace. Rename it to application-x-solvespace.png because that's the mime type we used for the files.

Then run xdg-icon-resource install --novendor --context mimetypes --size 48 application-x-solvespace.png and all your slvs files will now have icons in nautilus. If you have the directory open already, you might need to hit F5 to refresh it.

Update: I changed everything from x-slvs to x-solvespace as that's probably what it should have been and appears to be what Solvespace will be using.

edit flag offensive delete link more

Comments

@Samuel Sieb Good idea; unfortunately it did not work. I added a .desktop file as you suggested (details added to the top post), and restarted File Manager.

wolfv gravatar imagewolfv ( 2016-07-25 17:48:52 -0600 )edit

@Samuel Sieb, I did the mime file as you suggested, but no joy. Details are at end of top post.

wolfv gravatar imagewolfv ( 2016-07-25 19:06:24 -0600 )edit

Sorry, I forgot the --novendor parameter.

ssieb gravatar imagessieb ( 2016-07-25 21:33:47 -0600 )edit

@Samuel Sieb, that didn't work either, but thanks for the effort.

wolfv gravatar imagewolfv ( 2016-07-25 22:33:08 -0600 )edit

I followed my steps and it worked. Restarts are not required, everything gets picked up automatically. Are you sure that /usr/local/bin/solvespace can be run? I found that it didn't show up until I put a real executable in the desktop file.

ssieb gravatar imagessieb ( 2016-07-26 00:23:07 -0600 )edit
0

answered 2017-06-02 05:03:25 -0600

leotho gravatar image

I had the same problem, and to solve it I had to follow the steps proposed by Samuel Sieb (thanks to you) but also to edit a file : /usr/share/applications/gnome-mimeapps.list, and to add a line in this list. I'm absolutely not an expert but I'm glad if this can help for the next readers.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-07-25 09:11:11 -0600

Seen: 2,004 times

Last updated: Aug 09 '16