Fedora24 Boot Problem[TripleBoot]

asked 2016-07-21 08:24:56 -0500

G-dumb gravatar image

I have problem booting Fedora24 with manjarolinux grub2 boot screen.. Someone over the Manjaroo have writen a custom.cfg for me to boot Fedora24-kernel 4.5.5(I'm not sure the stock kernel come with the .iso), with that custom.cfg I manage to boot Fedora24 successfully, But.. After I updated Fedora24 to kernel 4.6.3 the custom.cfg didn't work and the guy over Manjaroo support forum ask me tu edit the custom.cfg files.. when I try to boot Fedora24-kernel4.6.6 the grub say

**error: file '/vmlinuzz-46.3-300fc24.x86_64' not found. error: you need to load the kernel first.

press any key to continue...._**

heres the original custom.cfg

menuentry 'Fedora (4.5.5-300.fc24.x86_64) 24 (Twenty Four)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.5.5-300.fc24.x86_64-advanced-1ffa905a-0703-41c5-9042-6fb9cb9c9a04' {
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos6'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6' 1975bf5b-8ea8-48be-9d7f-827181cde1cb
else
search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb
fi
linux16 /vmlinuz-4.5.5-300.fc24.x86_64 root=UUID=1ffa905a-0703-41c5-9042-6fb9cb9c9a04 ro rd.luks.uuid=luks-1ca05b7d-b2ca-4be0-8a65-5588374a6fe9 rhgb quiet LANG=en_US.UTF-8
initrd16 /initramfs-4.5.5-300.fc24.x86_64.img
}

menuentry 'Fedora - revised ' --class fedora {
set root='hd0,msdos6'
search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb
linux16 /vmlinuz-4.5.5-300.fc24.x86_64 root=UUID=1ffa905a-0703-41c5-9042-6fb9cb9c9a04 ro rd.luks.uuid=luks-1ca05b7d-b2ca-4be0-8a65-5588374a6fe9 rhgb quiet LANG=en_US.UTF-8
initrd16 /initramfs-4.5.5-300.fc24.x86_64.img
}

menuentry "Fedora - Configfile " {
insmod part_msdos
insmod ext2
search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb
configfile /boot/grub2/grub.cfg
}

here my version of the edited custom.cfg

menuentry 'Fedora (4.6.3-300.fc24.x86_64) 24 (Twenty Four)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.6.3-300.fc24.x86_64-advanced-1ffa905a-0703-41c5-9042-6fb9cb9c9a04' {

load_video set gfxpayload=keep insmod gzio insmod part_msdos insmod ext2 set root='hd0,msdos6' if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6' 1975bf5b-8ea8-48be-9d7f-827181cde1cb else search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb fi linux16 /vmlinuz-4.6.3-300.fc24.x86_64 root=UUID=1ffa905a-0703-41c5-9042-6fb9cb9c9a04 ro rd.luks.uuid=luks-1ca05b7d-b2ca-4be0-8a65-5588374a6fe9 rhgb quiet LANG=en_US.UTF-8 initrd16 /initramfs-4.6.3-300.fc24.x86_64.img }

menuentry 'Fedora - revised ' --class fedora { set root='hd0,msdos6' search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb linux16 /vmlinuz-4.6.3-300.fc24.x86_64 root=UUID=1ffa905a-0703-41c5-9042-6fb9cb9c9a04 ro rd.luks.uuid=luks-1ca05b7d-b2ca-4be0-8a65-5588374a6fe9 rhgb quiet LANG=en_US.UTF-8 initrd16 /initramfs-4.6.3-300.fc24.x86_64.img }

menuentry "Fedora - Configfile " { insmod part_msdos insmod ext2 search --no-floppy --fs-uuid --set=root 1975bf5b-8ea8-48be-9d7f-827181cde1cb configfile /boot/grub2/grub.cfg }

the custom.cfg reside in Manjaro /boot/grub

how can I boot Fedora24 with kernel 4.6.3

any help is appreciated

edit retag flag offensive close merge delete

Comments

It looks like GRUB can't find your initramfs files. Can you boot into rescue mode or use a rescue disk to get into Fedora and provide the output of:

lsblk

ls /boot

I believe that package managers keep your most recent kernels so that you can boot using an older kernel in case something went wrong with a newer one. So when you updated your kernel you probably lost one of your older kernels from that list. My guess is that that older kernel is the one you've been booting into all this time and that you just need to update grub to use your current set of kernels.

glitchyme gravatar imageglitchyme ( 2016-07-23 07:58:01 -0500 )edit