Ask Your Question
2

dnf uses wrong release version after upgrade to Fedora 24

asked 2016-07-15 03:27:39 -0600

terminus gravatar image

updated 2016-07-25 09:53:06 -0600

florian gravatar image

I upgraded Fedora (Workstation edition, Gnome desktop, x86_64) from version 23 to 24 using the recommended upgrade method. However, dnf still seems to default to checking the repositories for version 23 instead of 24. If I use --releasever=24 it works as expected, but otherwise it always uses version 23. The content of /etc/redhat-release is:

Fedora release 24 (Twenty Four)

So it's not getting the version number from there. How can I make 24 the default version for dnf?

Update: the output of rpm -q fedora-release is:

fedora-release-23-1.noarch
fedora-release-24-2.noarch

The content of /etc/yum.repos.d/fedora.repo is:

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=14d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

And the content of /etc/yum.repos.d/fedora-updates.repo is:

[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False
edit retag flag offensive close merge delete

Comments

How do your .repo files look like? Please post output of /etc/yum.repos.d/fedora.repo, and /etc/yum.repos.d/fedora-updates.repo

florian gravatar imageflorian ( 2016-07-15 11:32:58 -0600 )edit

What is the output of rpm -q fedora-release?

ssieb gravatar imagessieb ( 2016-07-15 14:19:58 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-07-25 13:58:27 -0600

ssieb gravatar image

For some reason you still have the 23 release file installed. dnf remove fedora-release-23 should fix your problem.

edit flag offensive delete link more

Comments

That's fixed it. Thanks for your help!

terminus gravatar imageterminus ( 2016-07-26 03:17:20 -0600 )edit
0

answered 2016-07-16 00:52:10 -0600

davidva gravatar image
su
dnf -y install fedora-release-24
edit flag offensive delete link more

Comments

That package is already installed, so I'm afraid that didn't work.

terminus gravatar imageterminus ( 2016-07-25 03:51:12 -0600 )edit

use dnf -y reinstall fedora-release-24

florian gravatar imageflorian ( 2016-07-25 09:51:23 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-07-15 03:27:39 -0600

Seen: 2,366 times

Last updated: Jul 25 '16