Ask Your Question
0

F24 | Huawei Modem Recognized as a CD-ROM

asked 2016-07-09 20:32:29 -0600

kmoharrum gravatar image

Hi,

I updated my F23 to F24 using dnf today, after the upgrade finished, I tried connecting my Huawei E177 with no luck, it does not appear in the NetworkManager applet. I started and enabled ModemManager:

systemct start ModemManager.service
systemct enable ModemManager.service

with no luck also, dmesg shows:

[ 82.002571] usb 2-1.1: new high-speed USB device number 4 using ehci-pci [ 82.089835] usb 2-1.1: New USB device found, idVendor=12d1, idProduct=1446 [ 82.089841] usb 2-1.1: New USB device strings: Mfr=3, Product=2, SerialNumber=0 [
82.089843] usb 2-1.1: Product: HUAWEI Mobile [ 82.089845] usb 2-1.1: Manufacturer: HUAWEI Technology [
82.325561] usb-storage 2-1.1:1.0: USB Mass Storage device detected [
82.325921] scsi host6: usb-storage 2-1.1:1.0 [ 82.326045] usb-storage 2-1.1:1.1: USB Mass Storage device detected [ 82.326113] scsi host7: usb-storage 2-1.1:1.1 [ 82.326221] usbcore: registered new interface driver usb-storage [ 82.334124] usbcore: registered new interface driver uas [ 83.330500] scsi 7:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2 [
83.330637] scsi 6:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2 [ 83.331448] sd 7:0:0:0: Attached scsi generic sg2 type 0 [
83.336715] sr 6:0:0:0: [sr1] scsi-1 drive [ 83.337154] sr 6:0:0:0: Attached scsi CD-ROM sr1 [
83.337445] sd 7:0:0:0: [sdb] Attached SCSI removable disk [ 83.337490] sr 6:0:0:0: Attached scsi generic sg3 type 5 [ 1070.357495] usb 2-1.1: USB disconnect, device number 4

Disks utility shows two Huawei devices, tried to unmount them with no luck also.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Once you have connected your Huawei Modem, try to eject the device from the file explorer (the one registered as a CD ROM device). Then it will try to register it as a modem device. Then your network manager applet should most probably pick it up.

anishjp gravatar imageanishjp ( 2016-07-11 09:48:09 -0600 )edit

No thats not working.

kmoharrum gravatar imagekmoharrum ( 2016-07-20 06:00:25 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-07-20 06:34:00 -0600

kmoharrum gravatar image

Found a solution @Red Hat Bugzilla thanks to alexhorov:

  1. Run lsusb
  2. Grab your modem vendorId and productId which in my case 12d1 and 1446
  3. Run usb_modeswitch -v 12d1 -p 1446 -J
  4. Enjoy
edit flag offensive delete link more

Comments

Worked for me in my Fedora - Cinnamon. It worked out of the box of Fedora - gnome but for Fedora - Cinnamon I had to run usb_modeswitch.

anishjp gravatar imageanishjp ( 2016-07-21 14:43:34 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2016-07-09 20:32:29 -0600

Seen: 599 times

Last updated: Jul 20 '16