Ask Your Question
0

FC17 Samba/Permissions

asked 2012-07-21 12:46:10 -0600

William gravatar image

updated 2014-09-28 23:56:50 -0600

mether gravatar image

Hey all. I've upgraded to FC 17 from FC 6 (yeah, I know...but the old system just kept working!), and now Samba is not playing nice with the other machines on my network (Windows Vista and some elderly variant of OS X). I've been all over the Samba end of this, and at this point, I'm pretty sure there's been some key change in permissions somewhere along the line. The shared directories do show up in the network I/F's on the client machines; however, once I double-click the username or homes icons, I get the following message: "Windows cannot access \" Check the spelling of the name. Otherwise, there might be a problem with your network..." The "details" button provides Error Code 0x80070005 Access is Denied.

Samba is running. (3.6.6-91.fc17) smbuser has been added, with password identical to the linux user password. Firewall is disabled. SELinux is disabled. /home/ chmodded to "maximum slutty" 777 The username is properly mapped in /etc/samba/user.map. I can put /etc/samba/smb.conf up (plus the contents of /var/log/whatever) if anyone's interested, but I've been up and down samba and I no longer believe it's the source of my discontent. Any ideas as to how I should attack this problem would be appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-24 16:05:41 -0600

jmt gravatar image

Even though you have disabled the firewall, you might still have iptables.service running. You can check that with

systemctl status iptables.service

If the service is running, stop it with

systemctl disable iptables.service
systemctl stop iptables.service
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-21 12:46:10 -0600

Seen: 2,375 times

Last updated: Apr 28 '13