Ask Your Question
0

Upgrading to fedora24, bitcoin has troubles.

asked 2016-07-07 21:22:45 -0600

centinel20 gravatar image

So I am upgrading to fedora24 and once I follow this steps, i get the following error:

    $ sudo dnf system-upgrade download --releasever=24
Bitcoin for Fedora - x86_64                      76  B/s | 335  B     00:04    
Fedora 24 - x86_64 - Updates                    905 kB/s | 8.5 MB     00:09    
Last metadata expiration check: 0:03:38 ago on Thu Jul  7 20:42:11 2016.
Error: package bitcoin-server-0.12.1-1.fc23.x86_64 requires libboost_chrono.so.1.58.0()(64bit), but none of the providers can be installed.
package bitcoin-utils-0.12.1-1.fc23.x86_64 requires libboost_filesystem.so.1.58.0()(64bit), but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

What happens if I --allowerasing ? I got the repository from this page They don't seem to have fedora 24 there yet but when drop box doesn't update their repositories fedora just keeps the latest version. So should I wait for that page to update they repo? Is there somewhere I can get those missing packages? What is the easiest thing to do which wont mess up my bitcoin server cus it takes a long time to set-up. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-08-24 17:58:50 -0600

centinel20 gravatar image

Ok so I just needed to wait until the repository was updated. Fedora24 is now up and running with bitcoin fullnode

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-07-07 21:22:45 -0600

Seen: 254 times

Last updated: Aug 24 '16