Ask Your Question
0

Cpu 100% problem on fedora 24

asked 2016-07-05 01:18:45 -0500

Evotis gravatar image

Hi,

I installed fedora 24 a few days ago, and i noticed that my CPU have big problems as soon as I launch a graphical application (like a small game, or a video player), the 4 core immediately jump to 100% each.

My cpu is a : Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz so nothing extra-ordinary, but it should be more than enough to watch a video or this kind of things, I see why is would behave like that.

Does anyone have a similar problem / knows a possible solution ? Thanks !

edit retag flag offensive close merge delete

Comments

1

Please, show us the output of the top command.

jorti gravatar imagejorti ( 2016-07-05 02:47:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-05 03:46:37 -0500

Evotis gravatar image

updated 2016-07-05 03:47:08 -0500

Here you go

top - 10:40:28 up  5:36,  2 users,  load average: 5.01, 2.79, 2.17
Tasks: 229 total,   2 running, 227 sleeping,   0 stopped,   0 zombie
%Cpu(s): 87.9 us,  3.6 sy,  3.5 ni,  5.0 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :  8124856 total,  1474448 free,  2479772 used,  4170636 buff/cache
KiB Swap:  8126460 total,  8126460 free,        0 used.  5235244 avail Mem 

    2 root      20   0       0      0      0 S   0.0  0.0   0:00.01 kthreadd                                      5050 evotis    20   0 2590424 301720  98296 S 203.6  3.7  52:39.61 vlc                                                                                 
 1690 evotis    20   0 2411644 458168  79348 R 134.3  5.6 151:36.94 gnome-shell                                  top - 10:40:31 up  5:36,  2 users,  load average: 5.25, 2.88, 2.20
Tasks: 229 total,   1 running, 228 sleeping,   0 stopped,   0 zombie
%Cpu(s): 87.2 us,  3.9 sy,  4.5 ni,  4.3 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :  8124856 total,  1471252 free,  2482860 used,  4170744 buff/cache
KiB Swap:  8126460 total,  8126460 free,        0 used.  5232144 avail Mem 


 5050 evotis    20   0 2590424 301720  98296 S 197.7  3.7  52:45.54 vlc                                                                                 
 1690 evotis    20   0 2411644 458168  79348 S 141.3  5.6 151:41.18 gnome-shell                                                                         
 1859 evotis    39  19 1681156  35984  23728 S  19.3  0.4   4:08.84 tracker-extract                                                                     
 1571 root      20   0  397668 127624  56956 S  17.3  1.6  32:40.82 Xorg                                                                                
 2315 evotis    20   0 2455192 981.5m 124160 S   3.7 12.4  41:50.13 firefox                                                                             
 3763 evotis    20   0 1639360  56792  31808 S   1.7  0.7   2:10.55 transmission-gt                                                                     
  657 root     -51   0       0      0      0 S   1.0  0.0   1:30.64 irq/39-iwlwifi                                                                      
 1702 evotis     9 -11  701720  20944  17464 S   1.0  0.3   5:42.22 pulseaudio                                                                          
 1903 evotis    20   0  599396  30080  13072 S   0.7  0.4   0:29.97 tracker-store                                                                       
 5650 root      20   0       0      0      0 S   0.3  0.0   0:00.13 kworker/u16:2
edit flag offensive delete link more

Comments

Thanks. The gnome-shell cpu usage is rather high. Which gpu do you have? Intel? You can check if Xorg is using gpu accelerated OpenGL with glxinfo. For example, in my case the rederer string is:

$ glxinfo | grep -i render
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
jorti gravatar imagejorti ( 2016-07-05 04:32:15 -0500 )edit

Seems like it is using it :

glxinfo | grep -i render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
Evotis gravatar imageEvotis ( 2016-07-05 04:36:44 -0500 )edit

spci |grep -i vga 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] $ 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

Thanks for your answers by the way !

Evotis gravatar imageEvotis ( 2016-07-05 04:39:02 -0500 )edit

You are not using GPU accelerated graphics. The gallium llvmpipe is a software emulator (only CPU). http://www.mesa3d.org/llvmpipe.html

Make sure you have installed xorg-x11-drv-ati

I have other system with a Radeon GPU and I have this settings in /etc/X11/xorg.conf.d/20-radeon.conf:

Section "Device"
        Identifier  "Radeon"
        Driver "radeon"
        Option "AccelMethod" "glamor"
        Option "DRI" "3"
        Option "TearFree" "on"
EndSection

You can check your Xorg logs with something like this:

# loginctl
# journalctl -b -u session-3.scope
jorti gravatar imagejorti ( 2016-07-05 05:41:20 -0500 )edit

The xorg-x11-drv-ati was already installed. But the file /etc/X11/xorg.conf.d/20-radeon.conf was not created, i created it and filled it with what you gave me. Hope that will change something ^^

Thanks for your replies !

Evotis gravatar imageEvotis ( 2016-07-05 06:45:16 -0500 )edit

Question Tools

3 followers

Stats

Asked: 2016-07-05 01:18:45 -0500

Seen: 1,618 times

Last updated: Jul 05 '16