Ask Your Question
0

Why are default compose-key combinations not working?

asked 2016-07-04 09:42:38 -0600

CamilB gravatar image

I enabled compose-key, and set it to be Caps Lock. It would work well, except the basic combinations aren't recognized (accented latin characters, for example, don't work).

Later, I installed xcompose, an alternative .XCompose file, placed in the home folder, and the combinations listed there work. For example, Compose, then "*", then "a" will type the letter Alpha, as expected. But Compose, then "apostrophe", then "e" won't type in the accented "e".

Where should I look?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-05 01:25:52 -0600

CamilB gravatar image

Apparently, the default compose file for my locale wasn't loaded by X.

I created the file ~/.XCompose, in which I wrote

include "/usr/share/X11/locale/en_US.UTF-8/Compose"

After logging out and back in, I can create accented characters with the compose key (é, ä, ø...).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-07-04 09:42:38 -0600

Seen: 153 times

Last updated: Jul 04 '16