Ask Your Question
0

Can't keep Gnome Terminal in dock with Plank

asked 2016-07-01 08:51:58 -0600

THpubs gravatar image

Normally we can pin items to the dock by right clicking the item and selecting keep in dock. But for gnome terminal, I won't see the keep in dock option. How can I fix that? I run plank in Fedora 24.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-02 08:20:57 -0600

devhen gravatar image

Its a bug with recent versions of gnome-terminal and it effects pretty much all docks (I use Docky). I had to create my own .desktop file for gnome-terminal and now it works. Create a file called gnome-terminal.desktop with these contents:

[Desktop Entry]
Version=1.0
Name=GNOME Terminal
GenericName=Command Line Terminal Program
Comment=gnome-terminal is the terminal emulator for GNOME3
Exec=gnome-terminal %U
Icon=gnome-terminal
StartupNotify=true
Terminal=false
Type=Application

And put it in /usr/share/applications/ or ~/.local/share/applications/. Restart or logout and back in.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-07-01 08:51:58 -0600

Seen: 1,034 times

Last updated: Jul 01 '16