Ask Your Question
0

Fedora 24 Nvidia gtx960 keeps crashing

asked 2016-06-29 06:51:32 -0600

Phil from Cumbria gravatar image

Hi, I recently bought an Nvidia GTX 960 card to update my system. Fedora 24 runs fine with Nouveau drivers but I wish to enable opencl for darktable and cinelerra etc with the Nvidia proprietry drivers. I have had several attempts at installing the nvidia drivers and whilst they do install and Nouveau is disabled the system just crashes after a minute or so. Has anyone got the nvidia GTX960 card working properly? and if so could you give me the correct commands please I have also tried this with arch and other fedora desktops with the same result. I suspect Nvidias linux driver is at fault.

My system Asus rampage 2 extreme mobo.
i7 intel quad core processor, 14Gb of ddr3 ram. Nvidia GTX 960 graphics card 750 watt psu 2 SSD's and 1 3GB HDD Thanks Phil

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-08 04:57:56 -0600

Phil from Cumbria gravatar image

Hi, Many thanks for your detailed reply. I will try your commands on another test install. One thing I have found out now is that if I go into the Nvidia GUI and change the power mizer setting from "auto" to "prefer maximum performance" the machine stays on. If I change it back to auto after a short while the level goes from 3 to 2 and the machine just dies again. I am wondering if I have a fault or on my mobo or it cannot somehow supply the reduced voltage, or it is not able to run the graphics card in the power saving mode. I have the latest BIOS released in 2011 which is obviously quite dated now. Will have another go but it could be time for a new mobo and processor.

edit flag offensive delete link more
0

answered 2016-06-29 11:16:23 -0600

wulfara gravatar image

updated 2016-06-29 12:33:37 -0600

Nice computer! I have not 960 but 950 GTX running with propietary drivers. I don't know if this will help you if you had the same problem in other distros (driver bug?) but this is what I did (all commands are run as root):

  • Install RPM Fusion repository:

dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

  • Update:

dnf update -y

  • Install Nvidia drivers:

dnf install akmod-nvidia "kernel-devel-uname-r == $(uname -r)"

  • Edit '/etc/default/grub' and add at the end of the GRUB_CMDLINE_LINUX line this parameters:

plymouth.enable=0 rdblacklist=nouveau nouveau.modeset=0 vga=0x31B

So now it looks like:

GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap plymouth.enable=0 rhgb quiet rd.driver.blacklist=nouveau nouveau.modeset=0 vga=0x31B"

Beware with this step because a mistake can get your system unbootable. If that happes you can edit the boot entry on the fly by pressing the "E" key while GRUB is showing to manually edit the parameters. You can try to edit the parameters on the fly and test if it works as expected before making the real changes to the GRUB config.

  • Apply new GRUB configuration:

grub2-mkconfig /boot/grub2/grub.cfg

  • If your system is 64 bits and you want to run 32 bits applications like Steam (provided by RPM Fusion too) install this package:

dnf install xorg-x11-drv-nvidia-libs.686

  • Reboot.

Hope this helps.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-06-29 06:51:32 -0600

Seen: 1,330 times

Last updated: Jun 29 '16