Ask Your Question
1

Vertical Touchpad Scroll persistence

asked 2016-06-25 13:15:27 -0600

Meaningless gravatar image

HI,

I managed to enable touchpad scrolling with the following command

$ xinput set-prop 12 "libinput Scroll Method Enabled" 0, 1, 0

It goes after a reboot. Can someone tell me how to default it please?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-25 16:03:46 -0600

galan gravatar image

First, why are you using this method to set touchpad properties? Assuming you are using a supported DE, the control center should offer up all the scroll methods supported by the union of your hardware capabilities and libinput. Second, if you're using libinput and xinput is working, then you are using libinput's xorg compatibility input driver. This means you can use the traditional xorg methods to set persistent options (see man xorg.conf.d).

Here's a link that will walk you through it: https://wiki.archlinux.org/index.php/...

edit flag offensive delete link more

Comments

yes add something like /etc/X11/xorg.conf.d/30-touchpad.conf

sergiomb gravatar imagesergiomb ( 2016-06-25 19:19:53 -0600 )edit
0

answered 2016-06-27 08:29:02 -0600

estebanknobl gravatar image

I experienced a similar problem and had to use synaptics. However, have in mind that synaptics is being deprecated, and that this workaround won't work on wayland. See this answer for more information.


I created "touchpad.conf" on /etc/X11/xorg.conf.d/

sudo nano /etc/X11/xorg.conf.d/touchpad.conf

And I put this inside:

Section  "InputClass"
      Identifier  "touchpad catchall"
      Driver  "synaptics"
      MatchIsTouchpad  "on"

      ####################################
      ## The lines that you need to add ##
      # Enable left mouse button by tapping
      Option  "TapButton1"  "1"
      # Enable vertical scrolling
      Option  "VertEdgeScroll"  "1"
      # Enable right mouse button by tapping lower right corner
      Option "RBCornerButton" "3"
      # Enable scroll middle button by tapping upper right corner
      Option "RTCornerButton" "2"
      # Velocity
      Option "MinSpeed" "1"
      Option "MaxSpeed" "1"
      ####################################

      MatchDevicePath  "/dev/input/event*"
EndSection

You should test how much velocity works for you. I like it fast. Also, you could check what other options you might want to set. I found this article very helpful.

I hope it helps.

Best regards, Esteban

edit flag offensive delete link more

Comments

hello again but how can configure: for example if put: "-1" slower? o r if i put 2 o 3 is slower? ans if i put 0 (zero) it would be neutro? thank

dextre gravatar imagedextre ( 2016-07-16 10:17:58 -0600 )edit

Question Tools

Stats

Asked: 2016-06-25 13:15:27 -0600

Seen: 310 times

Last updated: Jun 27 '16