Ask Your Question
0

Language support for Mozilla apps

asked 2012-05-09 16:41:58 -0600

viajeramental gravatar image

I've installed Firefox and Thunderbird from Fedora repositories but they are in english and I need them in spanish.

What I have to install to get them in the proper language?

Thanks very much!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-05-09 17:13:27 -0600

HoboPrimate gravatar image

updated 2012-05-09 17:48:20 -0600

I'm using the default Firefox that comes with Fedora 17, and it's already in my language (portuguese). I think this is a bug, because looking at the filesystem, the spanish language packs are installed by the firefox and thunderbird packages, like the following command show:

rpm -ql firefox | grep langpack-es

/usr/lib/firefox/langpacks/langpack-es-AR@firefox.mozilla.org.xpi
/usr/lib/firefox/langpacks/langpack-es-CL@firefox.mozilla.org.xpi
/usr/lib/firefox/langpacks/langpack-es-ES@firefox.mozilla.org.xpi
/usr/lib/firefox/langpacks/langpack-es-MX@firefox.mozilla.org.xpi

Try launching the applications like this (replacing es_ES with your language code):

LANG=es_ES.UTF-8 firefox
LANG=es_ES.UTF-8 thunderbird

do they appear in your language?

If not, then try this.

Install the correspondent .xpi file for your language code from here for firefox and here for thunderbird.

After restarting firefox, the new language should be enabled under Tools/Extras/Languages.

If even so, the new language isn't being used in the interface, just run again the applications like this:

LANG=es_ES.UTF-8 firefox
LANG=es_ES.UTF-8 thunderbird

This is probably a bug, could you report it?

edit flag offensive delete link more
0

answered 2012-05-09 17:06:43 -0600

ztank1013 gravatar image

About firefox you will probably have to re-install it in Spanish too:

http://www.mozilla.org/en-US/firefox/all.html

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-09 16:41:58 -0600

Seen: 1,716 times

Last updated: May 09 '12