Ask Your Question
0

Terrible Screen Tearing

asked 2016-06-21 22:50:16 -0500

PrimordialHelios gravatar image

I'm currently using KDE, and I'm getting some nasty screen tearing (it also happens in GNOME though). I tried disabling all kwin effects, and ran kwriteconfig --file kwinrc --group Compositing --key Enabled false, then restarted kwin, and it didn't help. I also tried Compton, and it didn't help. I've noticed this also happened in Ubuntu, and only after I upgraded to an AMD R7 370, so I'm thinking it's related to the GPU. I'm using the default drivers for everything, I haven't installed anything additional as far as drivers are concerned.

Screen tearing really bothers me, is there any way to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-21 23:21:45 -0500

ssieb gravatar image

updated 2016-06-21 23:23:27 -0500

Try installing driconf. Run it and see if vsync is enabled. You should not have to disable compositing and having compositing on might even help.

An even simpler test is to run glxgears from a terminal. The FPS should be close to 60.

edit flag offensive delete link more

Comments

Sorry for taking so long to respond. The output I get from glxgears is 299 frames in 5.0 seconds = 59.738 FPS (and yes, my monitor is 60 Hz). Strangely enough, this is the first time I've booted back into Fedora since asking this question, and my screen tear test ( 29.97 FPS) doesn't tear anymore except for at the very top of my main monitor. My secondary monitor still tears all over though.

EDIT: Everything else is still tearing even though the test went fine.

PrimordialHelios gravatar imagePrimordialHelios ( 2016-06-24 22:02:03 -0500 )edit

The main monitor is still tearing? It looks like vsync is enabled. What did driconf say? I've seen it mentioned in various places that the secondary monitor might not be able to avoid tearing, but the primary one should be ok. What are you doing where you see the tearing?

ssieb gravatar imagessieb ( 2016-06-26 00:32:16 -0500 )edit

Yes, the main monitor is tearing. Simply scrolling through a web page gives me tearing just above the half way point of the screen.

I can't seem to figure out where to look in driconf to figure out if vsync is enabled. How do I do that?

PrimordialHelios gravatar imagePrimordialHelios ( 2016-06-26 10:33:02 -0500 )edit

In the performance tab, the first option is "Synchronization with vertical refresh". What is the setting for that?

ssieb gravatar imagessieb ( 2016-07-03 15:47:14 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-21 22:50:16 -0500

Seen: 2,568 times

Last updated: Jun 21 '16