Ask Your Question
2

Puppet Certificate [closed]

asked 2012-07-16 15:48:11 -0600

abraham.sustaita gravatar image

I have a puppetmaster running CentOS 5.3. It has puppet version 0.25.4 and ruby 1.8. And I have a new server running puppet version 2.7.13 and ruby 1.9.3

When I run puppet agent --server puppet --test --waitforcert 1 --noop

I do receive err: Could not request certificate: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed. This is often because the time is out of sync on the server or client

But this is only in this server. I have another one with puppet 2.6.16 and ruby 1.8 and it works perfect. Googling it I have found it is a bug with ruby 1.9 and SSL certificates, and I have found how to fix this at Debian, but not at Fedora.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2018-10-21 23:00:39.202871

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-21 22:41:15 -0600

updated 2018-10-21 22:44:32 -0600

Is the time out of sync between your client and server? have you configured them both to use the same network time server? Wait, I just realised this hasn't been answered since it was asked in 2012...you've probably already resolved this.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-16 15:48:11 -0600

Seen: 152 times

Last updated: Oct 21 '18