Ask Your Question
0

What is the current entropy generator?

asked 2016-06-16 15:38:30 -0600

paulhr gravatar image

As per this#cite_note-3) link wiki page Fedora has a audio entropy package preinstalled. But the links are broken. What is the current entropy for Fedora 23? A search of this forum came up empty.

https://en.wikipedia.org/wiki/Entropy...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-16 15:58:49 -0600

ssieb gravatar image

updated 2016-06-17 10:42:59 -0600

Fedora primarily uses the default kernel entropy sources. There are a couple of packages available to increase the entropy available, such as audio-entropyd and haveged. If you do need more entropy, I would recommend using haveged.

The link to the audio-entropyd package information has moved to https://admin.fedoraproject.org/pkgdb...

edit flag offensive delete link more

Comments

I can not find any documentation on how to use it. I was able to install it using dnf. And I was able to start the service using systemctl start audio-entropyd. The https://www.vanheusden.com/aed/ page useless.

I have questions like... How does it find audio input? Just plug in a mp3 player into the audio jack and everything else is automatic? Does a microphone work? Does it have to be plugged into an audio source 24x7?

paulhr gravatar imagepaulhr ( 2016-06-16 17:23:59 -0600 )edit

The help on the command audio-entropyd says the default input is plughw:0

My Fedora has no such device.

audio-entropyd --help

Usage: audio-entropyd [options]

Collect entropy from a soundcard and feed it into the kernel random pool.

Options: --always_close, -a Always close sound device after use, even if pause-resume available. (Default no) --device, -d [] Specify sound device to use. (Default plughw:0) --entropy_filter, -e [] Filter to use for extracting entropy from the capture data. (Default 30) --lower_threshodd, -l [] When an entropy filter

paulhr gravatar imagepaulhr ( 2016-06-16 17:37:19 -0600 )edit

Use this to identify and test for the correct device

https://wiki.archlinux.org/index.php/...

geforce gravatar imagegeforce ( 2016-06-17 03:15:51 -0600 )edit

This is my output.

* List of PLAYBACK Hardware Devices *

card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

Subdevices: 1/1

Subdevice #0: subdevice #0

My guess is I should change the line in the configuration file /etc/sysconfig/audio-entropyd

from....

--device=plughw:0

to....

--device=plughw:0,0

Is that correct?

paulhr gravatar imagepaulhr ( 2016-06-17 07:15:41 -0600 )edit

That looks correct.

geforce gravatar imagegeforce ( 2016-06-17 07:27:52 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-16 15:38:30 -0600

Seen: 179 times

Last updated: Jun 17 '16