Ask Your Question
0

NTP suddenly missing

asked 2016-06-10 11:42:48 -0600

florian gravatar image

Something weird is going on...please help me to understand:

This morning I noticed that my clock was totally off (>1d), so I decided to start an ntp sync manually. But I realized that ntp wasn't even installed. ntp is part of the standard installation, right? Why did it go missing? I went through many past dnf transactions (sudo dnf history info <id>) and couldn't find an erase. So, let's say ntp was (for whatever reason) missing for a longer period, how come my computer clock was damn right? (Never set it manually) Does Gnome have any other way to set the clock? How can I find out when and why ntp went overboard?

(To fix my problem, I did dnf -y install ntp ntpdate and systemctl enable ntpd.service)

edit retag flag offensive close merge delete

Comments

Not a lot of help but dnf logs installs, upgrades, and clean up data in /var/log/dnf.rpm.log. Might be a clue as to at least when it happened.

Mordoc gravatar imageMordoc ( 2016-06-10 16:13:00 -0600 )edit

@Mordoc Thanks for you reply. I forgot to mention that. I went through all dnf.rpm.logs and all dnf.logs. The thing I was surprised of was that they are only kept for one (?) months. There were no logs older than that. Any idea where that setting is hidden?

florian gravatar imageflorian ( 2016-06-10 20:12:28 -0600 )edit

@florian Check /etc/logrotate.d/dnf for info on this. I would assume from your experience that the directive "rotate 4" would be every 4 weeks...

Mordoc gravatar imageMordoc ( 2016-06-20 17:07:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-06-14 13:12:31 -0600

ssieb gravatar image

The default NTP provider is chrony, not ntpd. If you go to the Date&Time control panel, there is a switch to turn on network time sync.

edit flag offensive delete link more

Comments

Ah, thanks. That switch didn't work, and I figured out that it was due to my corporate firewall that blocks NTP port. Still couldn't figure out why all of a sudden my clock was totally off.

florian gravatar imageflorian ( 2016-06-14 13:37:05 -0600 )edit

It's probably a Good Idea to discuss this with your IT department and find out if there's a proxy set up so that you can keep your clock synced from inside the firewall. (I've no idea why they're blocking the port, but if they're that paranoid you're more likely to get a proxy than to get it opened up.)

sideburns gravatar imagesideburns ( 2016-06-14 15:59:28 -0600 )edit

@sideburns: contacted them today about the issue. Will see.

florian gravatar imageflorian ( 2016-06-15 15:54:56 -0600 )edit
1

If your clock is suddenly off, I suggest checking the battery on the mainboard.

mithrial gravatar imagemithrial ( 2016-06-16 03:42:16 -0600 )edit

That's a good idea, as long as it's running slow. Not many people know it, but motherboards have been designed for decades to have the clock slow down as a warning that the battery needs replacing.

sideburns gravatar imagesideburns ( 2016-06-16 04:12:03 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-10 11:42:48 -0600

Seen: 174 times

Last updated: Jun 14 '16