Ask Your Question
0

Removing LXDE removed more stuff on my system

asked 2016-06-10 05:49:31 -0600

wookietookie gravatar image

I have to start a bit back with this issue.

I initially installed LXDE. It was working fine, but after I recovered from stand-by the first time, my system went crazy. I couldn't login anymore into LXDE, I just had a grey background (like the background on the login page) with my cursor and nothing happened. So I rebooted, but when I reached the F blue logo, the system just froze. I rebooted again and pressed Esc while the F was loading and after a series of FAILED lines that I couldn't even read (they were going down fast), I reached the login page, switched back to GNOME and logged in succesfully.

Here I basically had LXDE and GNOME mixed up. The screensaver especially, after locking my system, was LXDE's. And when I wanted to unlock it the LXDE interface showed up (even though I was using GNOME).

So I thought that since LXDE was messing up a lot, I could just uninstall it.

$ dnf groups remove "lxde"

This gave me an error on 2 dependencies (wine-core and mesa-something) and told me to use --allowerasing. I did and, well, I screwed up my system. The notebook crashed, rebooted by itself and got stuck on the F logo, so I rebooted again and pressed Esc and basically the same thing as before. But this time I didn't land on the login interface, I just had a black and white command line interface.

I logged in as root in this terminal and tried a bunch of things.

dnf update said it was all ok, but somehow I had sudo not installed. I tried to install gnome-shell or lxde-desktop, but it said they were already installed. So I logged out from root and logged in as my user, typed "startx" and finally reached my desktop.

How do I fix my system? I keep getting stuck at the F logo unless I press Esc, and I keep landing on that terminal instead of the login interface (even when I log out from the desktop).

EDIT: I tried to run again the dnf groups remove command and gave me this list. Why is it trying to get rid of gnome-shell??

edit retag flag offensive close merge delete

Comments

Since you are able to login to your terminal startx there to see if load gnome, that is to try to see what is going own. It is removing gnome because it is removing gnome-keyring-pam. my sugestion is to make sure that gdm is installed and if you want to remove lxde then remove it by packages not the group.

aeperezt gravatar imageaeperezt ( 2016-06-10 11:31:13 -0600 )edit

I executed that command and unisntalled everything, then through the terminal I installed GDM again and seems to work, but everytime I boot up I have to type startx to actually get to my desktop. How can I fix this?

wookietookie gravatar imagewookietookie ( 2016-06-10 14:32:10 -0600 )edit

can you check what init state you are when login, you can do so with

ls -la /etc/systemd/system/default.target

Output should be:

lrwxrwxrwx. 1 root root 36 abr  3  2014 /etc/systemd/system/default.target -> /lib/systemd/system/graphical.target

if not then you need to set you system to graphica.target to do so:

rm /etc/systemd/system/default.target

then

ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target

I you are on graphical.target then something else is missing

aeperezt gravatar imageaeperezt ( 2016-06-10 16:49:12 -0600 )edit

Ok I solved it buy removing GDM and completely reinstalled it. Thanks guys.

wookietookie gravatar imagewookietookie ( 2016-06-12 03:55:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-10 16:34:35 -0600

sergiomb gravatar image

this is a big bug in dnf https://bugzilla.redhat.com/show_bug.... the quickest solution is add to /etc/dnf/dnf.conf :
clean_requirements_on_remove=false

edit flag offensive delete link more

Comments

Thank you, I'll pay more attention next time I'll "dnf remove" something.

wookietookie gravatar imagewookietookie ( 2016-06-12 03:57:28 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-10 04:03:10 -0600

Seen: 373 times

Last updated: Jun 10 '16