Ask Your Question
0

Unable to uninstall Libreoffice

asked 2013-02-09 08:02:52 -0600

Robert gravatar image

updated 2014-05-07 15:36:33 -0600

mether gravatar image

Hi,

I am new to Fedora and trying to learn the software package management especially through terminal using commands

I removed libreoffice using following command on the terminal

yum remove libreoffice*

which removed the entire Libre office suit and it does not appear under Applications --> Office anymore

After sometime I tried to reinstall Libreoffice using following command

[root@fedora RPMS]# yum install *.rpm

I ran this command from the RPMS directory in the downloaded suit of libreoffice

It gave me following output

Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Examining libobasis4.0-base-4.0.0.3-103.x86_64.rpm: libobasis4.0-base-4.0.0.3-103.x86_64
libobasis4.0-base-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-calc-4.0.0.3-103.x86_64.rpm: libobasis4.0-calc-4.0.0.3-103.x86_64
libobasis4.0-calc-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core01-4.0.0.3-103.x86_64.rpm: libobasis4.0-core01-4.0.0.3-103.x86_64
libobasis4.0-core01-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core02-4.0.0.3-103.x86_64.rpm: libobasis4.0-core02-4.0.0.3-103.x86_64
libobasis4.0-core02-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core03-4.0.0.3-103.x86_64.rpm: libobasis4.0-core03-4.0.0.3-103.x86_64
libobasis4.0-core03-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core04-4.0.0.3-103.x86_64.rpm: libobasis4.0-core04-4.0.0.3-103.x86_64
libobasis4.0-core04-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core05-4.0.0.3-103.x86_64.rpm: libobasis4.0-core05-4.0.0.3-103.x86_64
libobasis4.0-core05-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core06-4.0.0.3-103.x86_64.rpm: libobasis4.0-core06-4.0.0.3-103.x86_64
libobasis4.0-core06-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-core07-4.0.0.3-103.x86_64.rpm: libobasis4.0-core07-4.0.0.3-103.x86_64
libobasis4.0-core07-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-draw-4.0.0.3-103.x86_64.rpm: libobasis4.0-draw-4.0.0.3-103.x86_64
libobasis4.0-draw-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-4.0.0.3-103.x86_64
libobasis4.0-en-US-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-base-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-base-4.0.0.3-103.x86_64
libobasis4.0-en-US-base-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-calc-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-calc-4.0.0.3-103.x86_64
libobasis4.0-en-US-calc-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-math-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-math-4.0.0.3-103.x86_64
libobasis4.0-en-US-math-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-res-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-res-4.0.0.3-103.x86_64
libobasis4.0-en-US-res-4.0.0.3-103.x86_64.rpm: does not update installed package.
Examining libobasis4.0-en-US-writer-4.0.0.3-103.x86_64.rpm: libobasis4.0-en-US-writer-4.0.0.3-103.x86_64
libobasis4.0-en-US-writer-4.0.0.3-103 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-11 12:33:19 -0600

Robert gravatar image

I discussed above problem with one of my friend and he explained that the Libreoffice which I installed earlier is not removed when I ran following command

yum remove libreoffice*

I could not understand the technical reason which he told me. However he suggested following

yum remove libreoffice*

and that worked for me. Then the libreoffice was removed completely and I was able to reinstall it.

Once again I really appreciate your help. Keep posting!

edit flag offensive delete link more
1

answered 2013-02-10 19:03:38 -0600

FranciscoD_ gravatar image

Please check your yum history to see if it actually removed your packages. Was the transaction interrupted sometime? It's quite possible that your database is corrupted and this can be fixed.

First, confirm that the package was removed by checking your yum history:

yum clean all #Just for the sake of it, remove all current metadata
yum history list #list transactions
yum history info <transaction number> #see details on the transaction

If it was, then your database could be corrupted. (Not sure why/how)

rm -fv /var/lib/rpm/__db* #deletes the rpm database
rpm --rebuilddb #rebuilds the rpm database
yum clean all
yum update #see if it works
yum <whatever command>
edit flag offensive delete link more

Comments

this works for me

trendies1000 gravatar imagetrendies1000 ( 2014-09-20 17:40:01 -0600 )edit

Question Tools

Stats

Asked: 2013-02-09 08:02:52 -0600

Seen: 23,840 times

Last updated: Feb 11 '13