Ask Your Question
0

How to switch to 32 bit color depth in Fodora 16

asked 2011-11-23 15:19:08 -0600

ztank1013 gravatar image

I got a warning message from Virtual Box while my RHEL 6.0 VM was booting from DVD iso image for the first install. The warnig suggested to switch to 32 bit color depth mode.
The host OS is a Fedora 16 (x86_64) and it is probably configured with 16 or 24 bit color depth but I don't know how to check it.

How can I swith to 32 bit color depth?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2011-11-23 15:25:29 -0600

hhlp gravatar image

updated 2011-11-24 07:29:41 -0600

before starting the virtual machine, configure the follow in your new one...

select the virtual machine -> double click -> settings -> display

image description

I installed Fedora on my Virtualbox and the first problem that greeted me when I boot up is the 16-bit display error message:

The virtual machine window is optimized to work in 32 bit color mode but the virtual display is currently set to 16 bit. Please open the display properties dialog of the guest OS and select a 32 bit color mode, if it is available, for best possible performance of the virtual video subsystem.

Note. Some operating systems, like OS/2, may actually work in 32 bit mode but report it as 24 bit (16 million colors). You may try to select a different color mode to see if this message disappears or you can simply disable the message now if you are sure the required color mode (32 bit) is not available in the guest OS.

It stated that your system is optimized to work in 32-bit, but the color quality is set to 16-bit. First of all, there is no “display properties” in Fedora that allows you to change from 16-bit to 32-bit. Secondly, when you open the monitor option, you can only select 800×600 (or lower) screen resolution.

Here’s what I did to solve the problem.

  1. Install Guest Addition. Do not restart after the installation has finished. (how install guest addition ( http://ask.fedoraproject.org/question/386/virtual-box-41-install)

  2. Open a terminal (in your Fedora guest) and type :

    sudo nano /etc/X11/xorg.conf

    change DefaultDepth 24 (to 32)

Save and close the file.

  1. Restart the VM.

It should work now.

edit flag offensive delete link more

Comments

when you install the guest addition it creates the xorg.conf file...

hhlp gravatar imagehhlp ( 2011-11-24 13:09:44 -0600 )edit
0

answered 2011-11-23 22:50:58 -0600

The answer is a bit more complex then that.

first, you need to install the guest additions (in the guest) and increase the amount of ram and features (3d) available to the guest (3d is not the same as 32 bit color depth)

second, you need to edit /etc/X11/xorg.conf and add 24 bit depth

Section "Screen" Identifier "Default Screen" Device "VirtualBox graphics card" Monitor "Generic Monitor" DefaultDepth 24 EndSection

In linux 24 guests, use a default depth of 24. I can not find a detailed discussion of depth, but, from an older xorg man page

Quote - "The range of depth values that are allowed depends on the driver. Most driver support 8, 15, 16 and 24. Some also support 1 and/or 4, and some may support other values (like 30). Note: depth means the number of bits in a pixel that are actually used to determine the pixel colour. 32 is not a valid depth value. Most hardware that uses 32 bits per pixel only uses 24 of them to hold the colour information, which means that the colour depth is 24, not 32."

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-23 15:19:08 -0600

Seen: 10,457 times

Last updated: Nov 24 '11