Ask Your Question
1

yesod init is not working

asked 2016-05-27 16:39:58 -0600

shab gravatar image

I installed haskell platform then

cabal update
cabal install cabal-install
cabal install yesod-bin

bun when i write

yesod init

i get this error

bash: yesod: command not found...

what should I do ?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-05-29 05:16:09 -0600

snowolfe gravatar image

I know nothing about yesod, but the most likely reasons are:

  • the binary/executable is not called yesod in which case you need to identify the correct executable name - there may be other ways, but sudo find / -iname '*yesod*' would do as a fairly crude mechanism.
  • the executable is not in your $PATH - if you can locate it (see previous step), then add it to your .bash_profile file;

echo 'PATH=$PATH:/path/to/yesod; export $PATH' >> ~/.bash_profile

edit flag offensive delete link more
1

answered 2016-05-29 22:05:49 -0600

rdes gravatar image

snowolfe is correct you need to update your path, but it's the path for cabal. Which should be

PATH=$PATH:$HOME/.cabal/bin

You might also want to checkout stack. It has really good documentation and is a bit more user friendly.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-05-27 16:39:58 -0600

Seen: 91 times

Last updated: May 29 '16