Ask Your Question
2

How can I change brightness of laptop on Fedora 15 or 16 ? [closed]

asked 2011-11-11 07:11:41 -0600

Tommytom gravatar image

With Fedora 14, I write directly in file /proc/acpi/video/VID/LCD/brightness, but on F15 and 16, this file doesn't exist. How I suppose to do?

On laptop (Dell M1330)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by zoltanh721
close date 2014-06-27 17:27:28.644557

10 Answers

Sort by » oldest newest most voted
2

answered 2012-01-16 22:04:03 -0600

elpaquete gravatar image

This works for me on Fedora 16

/sys/class/backlight/acpi_video0/brightness

In my case, values go from 0 (off) to 10 (full).

edit flag offensive delete link more
0

answered 2011-11-15 21:02:18 -0600

E. Lewis gravatar image

The blue function key plus down arrow to dim the screen, the blue function key plus up arrow to brighten the screen. That has worked in all of our Dell laptops no matter what they run, Fedora, Ubuntu, Microsoft.

edit flag offensive delete link more
0

answered 2012-08-22 02:39:31 -0600

echo 3 > /sys/class/backlight/acpi_video0/brightness where you can replace 3 by 0 to 7

edit flag offensive delete link more
0

answered 2012-02-19 05:24:31 -0600

DJL gravatar image

I have a ASUS and when i use FN+F5 or F5 don't change the brightness.

edit flag offensive delete link more
0

answered 2012-02-19 05:22:22 -0600

DJL gravatar image

I have a ASUS and if I use the FN+F5 or F6 dont change brightness.

edit flag offensive delete link more
0

answered 2011-11-13 16:14:43 -0600

mether gravatar image

What desktop environment are you using?

edit flag offensive delete link more
0

answered 2012-01-11 12:22:20 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

go to the file "/sys/class/backlight" you should be able to find your way from there !

edit flag offensive delete link more
0

answered 2012-01-11 13:11:31 -0600

skytux gravatar image

For command line usage:

# yum install xbacklight

$ xbacklight -set 70

HTH, Germán.

edit flag offensive delete link more

Comments

This worked perfectly and was much simpler than echoing to a system config file.

bananaoatman gravatar imagebananaoatman ( 2015-04-28 21:32:44 -0600 )edit

I'm glad it worked... please vote! :-)

skytux gravatar imageskytux ( 2015-04-29 15:00:50 -0600 )edit
0

answered 2012-02-02 04:01:23 -0600

FranciscoD_ gravatar image

Also a known bug. See if this is what you're hitting. rhbz#753012

edit flag offensive delete link more
0

answered 2012-02-02 08:33:30 -0600

thunderbirdtr gravatar image

Add to grub line this ;

  acpi_backlight=vendor
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-11 07:11:41 -0600

Seen: 13,154 times

Last updated: Aug 22 '12