Ask Your Question
1

Wifi connection dropping with RTL8188CE / Right driver installed? Which is the right driver?

asked 2016-05-03 14:11:04 -0600

gobigobi66 gravatar image

updated 2016-05-03 14:37:06 -0600

Hi,

My problem is that my wifi connection is frequently dropping. I am running Fedora 23 with up-to-date kernel (4.4.8). I didn't have such problems with Fedora 22, but unfortunately I can't recall when the problem started. My current workaround is activating and deactivating airplane-mode. After that, it connects again...until it drops connection. It happens on whatever wifi AP, which let's me think that it is not related to my router. Moreover, none of the other devices in our household has a problem.

I running with whatever driver the system selected for me. Nothing manually installed in that regards, which leads me to my first question. Which is the best driver for a wifi card with RTL8188CE chipset?

lspci :

Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. Device 8195
Flags: bus master, fast devsel, latency 0, IRQ 17
Kernel driver in use: rtl8192ce
kernel modules: rtl8192ce

lsmod | grep wifi:

rtlwifi                73728  3 rtl_pci,rtl8192c_common,rtl8192ce
mac80211              700416  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              552960  2 mac80211,rtlwifi

modinfo mac80211: (Not sure this information is any useful..)

filename:  /lib/modules/4.4.8-300.fc23.x86_64/kernel/net/mac80211/mac80211.ko.xz
[...]
parm:  max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:  max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:  beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:  probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:  ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

dmesg | grep rtl:

[   70.450505] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[   70.480133] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   70.480649] rtlwifi: rtlwifi: wireless switch is on
[   70.535069] rtl8192ce 0000:03:00.0 wlp3s0: renamed from wlan0
[ 4595.565642] rtlwifi: rtlwifi: wireless switch is on

What else would like to see to help me troubleshooting this problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-30 07:39:34 -0600

arthurhe gravatar image

I was having a similar (if not the same) problem when connecting to the internet using the 8188CE card. After a long time and several attempts trying to identify and fix the issue, I found this modified driver which seems to have improved the situation. Have a look here:

https://github.com/FreedomBen/rtl8188ce-linux-driver

Basically, I ran the automatic installation using git and the internet connection seems to be way more stable. Here is the command:

git clone https://github.com/FreedomBen/rtl8188ce-linux-driver.git && cd rtl8188ce-linux-driver && ./install.sh

I am not sure if this will fix your issue, but it sure looks similar to the issue I was having. Also, as this is a non-official driver, proceed at own risk and make sure to read all the documentation provided at the website before proceeding. In my case, though, it sure seems to have helped. Hope it can help you as well, as this problem was driving me mad.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-05-03 14:11:04 -0600

Seen: 920 times

Last updated: Jan 30 '17