Ask Your Question
0

How to use grsync to backup through ssh?

asked 2016-05-01 09:53:44 -0600

gabriele gravatar image

I use rsync to backup to another pc through ssh and it works properly. Then I tried to do the same using grsync (with the same parameters used with rsync) and having some issues, since I'm not prompted to insert the password for ssh authentication, so the backup doesn't start. What/how do I have to configure to make it work?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-01 13:53:01 -0600

aeperezt gravatar image

Since your issue is with the password over ssh, what you could do is generate an ssh key on the pc where you run the grsync:

ssh-keygen

Follow the steps but set no password to it.

The the other machine check if you have .ssh folder and if you have add the authotized_keys file and copy the content of the id_rsa.pub file from the other machine .ssh/ folder make sure the .ssh folder is read ony by the user with chmod 700 and the authorized_keys file own buy the user.

You can test this is working by login using ssh to the other machine it should not ask for password if the settings are correct. If works then de grsync should work with password.

Hope this help.

edit flag offensive delete link more

Comments

Thank you for your answer, but unfortunately this doesn't work.

gabriele gravatar imagegabriele ( 2016-05-01 14:25:44 -0600 )edit

Could you ssh into the other machine with out using password? if not then something is wring on your config

aeperezt gravatar imageaeperezt ( 2016-05-01 15:12:42 -0600 )edit

No, after generating the ssh key it continues to ask the password to connect to the remote machine with ssh. I tried from two different machines and the result is the same. Moreover I tried to use grsync from an Ubuntu machine and the backup through ssh works correctly in that case, even without generating any ssh key.

gabriele gravatar imagegabriele ( 2016-05-01 15:48:27 -0600 )edit

if you cannot ssh into from one machine to the other with ssh and no password then keys are not set correctly look at https://docs.fedoraproject.org/en-US/...

aeperezt gravatar imageaeperezt ( 2016-05-01 15:55:53 -0600 )edit

Following the instructions at the link you reported I succeeded to SSH with no password request and with this work around I was able to use grsync. But in this way I'm forced to make a key based authentication instead of a password authentication and I have to import the public key to the machine I want to connect to. With the Ubuntu machine I'm able to do it also with password authentication. With Fedora it seems I miss something that is able to ask me for SSH password when using grsync. Do you have any idea how to fix this? When using CLI rsync it works correctly.

gabriele gravatar imagegabriele ( 2016-05-02 14:52:28 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-05-01 09:53:44 -0600

Seen: 491 times

Last updated: May 01 '16