Ask Your Question
2

How to solve boot problem caused by nvidia driver? (Oh no something has gone wrong)

asked 2016-04-13 16:59:23 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have installed the driver (.run file, downloaded by the nvidia website) for my nvdia GeForce 930M. Then i rebooted the system and I realized that I screwed up. I can't use the system anymore because I'm stuck in the screen "Oh no, something has gone wrong". I think that the solution is remove nvidia drivers and turn back to the default, right? But how do I do that? Or I can configure the drivers instead? Please, help me, I'm a newbie, using linux since last month. Thanks!

UPDATE: The output of lspci -vnn | grep -i nvidia is 04:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 930M] [10de:1346] (rev a2) For sure I have a nvidia card, Windows recognize it (dual boot)

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
4

answered 2016-04-14 00:30:37 -0600

hedayat gravatar image

updated 2016-04-25 00:45:54 -0600

Yes, remove the installed one first. As you've installed using nvidia .run installer, IIRC you can uninstall it using something like nvidia-uninstall.

However, notice that there is more than one nvidia drivers (3 or 4, at least 3 are in rpmfusion repos). I guess you have installed a driver which is not appropriate for your graphics card. It is better to look up in nvidia website to see which version of drivers is appropriate for your card, and install it.

rpmfusion.org repos provide these 3 versions: akmod-nvidia, akmod-nvidia-340xx and akmod-nvidia-304xx I suggest installing a driver from rpmfusion rather than nvidia .run installers, and I suggest akmod ones as they behave much better on kernel upgrades.

Install drivers (or using discreet GPU) for dual-GPU systems: Unfortunately, installing drivers for dual-GPU systems and/or enabling secondary GPU of these systems (and powering them off when they are not in use) still needs some special steps. For more details about dual-GPU systems with an NVidia card please refer to: https://fedoraproject.org/wiki/Bumblebee

Currently, you are using only your Intel GPU. Using the instructions in the given link, you can either use your NVidia GPU for 3D applications with nouveau drivers using PRIME, or using bumblebee with nvidia binary drivers (using nouveau with bumblebee is described but discouraged). Please read the document carefully before doing anything.

Surprisingly (for me at east!), the link claims that you might get better FPS with nouvea drivers already included in Fedora compared to nvidia binary drivers. You might try that first!

Installing drivers from RPMFusion repos: To install from rpmfusion repos, you should install/enable these repos first. As you can see in http://rpmfusion.org/Configuration , it can be done with this command:

su -c 'dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

Then, you can install one of these drivers using dnf install:

dnf install akmod-nvidia

or

dnf install akmod-nvidia-340xx

or

dnf install akmod-nvidia-304xx

I don't know which one is appropriate for you graphics card. You probably have tried the latest version already, so akmod-nvidia-340xx might be appropriate for you. However, the best method to find out which driver is for your card is to use nvidia website to determine which version is appropriate for you.

edit flag offensive delete link more

Comments

Thank you so much! The command nvidia-uninstall worked! Now, can you give me some help to install the driver using the rpmfusion? I mean, what commands I have to use? I'm using Fedora 23 in a notebook (Asus), Nvidia 930M. Thank you again :)

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-04-14 21:30:41 -0600 )edit

It seems really hard. Surprisingly (for me at east!), the link claims that you might get better FPS with nouvea drivers already included in Fedora compared to nvidia binary drivers. You might try that first! I don't get it. You're saying that it's better let thing the way they are right now?

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-04-24 18:30:39 -0600 )edit

No. Currently, you are not using your nvidia card under Linux at all. It is using your Intel GPU.

And I were wrong. It says using PRIME ( https://fedoraproject.org/wiki/Bumble... ) is better than using bumblebee with nouveau (not nvidia binary drivers).

You should read the link I gave you. There, you can find two solutions for using nvidia drivers: using nouveau drivers and using nvidia drivers. But, according to the docs, I encourage you to either follow the For free or open source solution section or For closed source solution

hedayat gravatar imagehedayat ( 2016-04-25 00:41:37 -0600 )edit
1

answered 2016-04-13 20:25:56 -0600

aeperezt gravatar image

Press ctrl+alt+f3 and you should get a to the console where you can can login with your user and remove the driver and do all you require to fix the issue.

edit flag offensive delete link more

Comments

Thanks for the answer. Actually, I can use the console. But I don't know how to remove nvidia drivers and enable nouveau.

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-04-13 20:31:46 -0600 )edit

Well depend on how you installed, if you use a rpm package you can do dnf history to see what was installed and undo it. Other way to go is check the nvida modules and add then into as a blacklisted modules on /etc/modprove.d/ you probably has blacklisted the nouveau module so you may need to remove it from the blacklist

aeperezt gravatar imageaeperezt ( 2016-04-13 21:57:45 -0600 )edit
1

answered 2016-12-13 06:48:06 -0600

cgvirus gravatar image

In Fedora 25 I had Used this method for installing Nvidia https://rpmfusion.org/Howto/nVidia

After kernel update to 4.8.13-300.fc25 I got "Ow no something went wrong"

Solved it:

ctrl+alt+f4

then

su 
akmods --force
rebbot

worked for me.

Thanks xmetax

edit flag offensive delete link more

Comments

Glad it helped!

xmetax gravatar imagexmetax ( 2017-01-11 14:18:05 -0600 )edit

Thank you so much! I have problem many years with fedora updates. akmods --forcesolve all !!!

Denis Savenko gravatar imageDenis Savenko ( 2017-01-18 22:34:05 -0600 )edit
1

answered 2016-04-15 21:59:49 -0600

xmetax gravatar image

I've fixed the "Oops something went wrong message" following the NVIDIA install by doing:

Alt + F2

Login

su
akmods --force

The NVIDIA kernel module builds.

reboot

Good luck!

edit flag offensive delete link more

Comments

1

OP has not even installed akmod packages, so this is not related to his problem. And it should not be required, unless previous builds of akmod has been failed for some reason (maybe older driver version not compatible with latest kernel, or having a debug kernel installed in addition to normal kernel).

hedayat gravatar imagehedayat ( 2016-04-15 23:18:14 -0600 )edit

Well hey, it fixed my problem. I was going the RPMFusion method to begin with, glad I read this!

scavy gravatar imagescavy ( 2017-07-06 23:33:09 -0600 )edit
0

answered 2016-04-17 09:36:44 -0600

benitezCarvalho gravatar image

Update: I have tried to install the drivers again, using the rpm fusion, just like hedayat said, but I had the same problem. So I could fix this time by running yum remove xorg-x11-drv-nvidia\* This tutorial ( http://rpmfusion.org/Howto/nVidia ) says that by the command /sbin/lspci | grep VGA I can discover my graphics card model, but the the return is: **00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)


Is that right?

edit flag offensive delete link more

Comments

1

Oh, so you either don't have any nvidia cards at all, or you have a dual GPU system. Would you plealse provide the output of lspci -vnn | grep -i nvidia too?

Note: to update your post, you can edit your own post and add the updated info there.

hedayat gravatar imagehedayat ( 2016-04-18 00:18:07 -0600 )edit

Thanks for advice. Main post updated ;)

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-04-19 17:41:58 -0600 )edit

:) grep VGA used to work, but I've seen recently that some GPUs are recognized as '3D controller' rather than VGA.

hedayat gravatar imagehedayat ( 2016-04-20 00:05:22 -0600 )edit

Exactly! The output of lspci | grep -E "VGA|3D" shows what you said: **00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) 04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev a2)


Screenshot: http://goo.gl/3QzWEa What should I do now?

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-04-20 18:47:07 -0600 )edit

Read my updated answer (section Install drivers (or using discreet GPU) for dual-GPU systems); it is updated already! :)

hedayat gravatar imagehedayat ( 2016-04-21 00:19:31 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-04-13 16:59:23 -0600

Seen: 33,701 times

Last updated: Dec 13 '16