Ask Your Question
2

Cannot boot from USB

asked 2013-01-30 20:36:51 -0500

abcdefghi123456789 gravatar image

So, I've put Fedora 17 on a live flash drive, but when I try to boot it, it says "secure boot not enabled" and takes me to a command line that says something about emergency mode and quitting the shell, etc, etc.

edit retag flag offensive close merge delete

Comments

Have you Windows 8[.1] installed too? if not not, AFAIK Fedora should not require secure boot enabled. Are you sure you have downloaded it from "http://get.fedoraproject.org"?

sea gravatar imagesea ( 2013-09-16 16:15:42 -0500 )edit

How did you prepare your USB stick for installation?

mohanprakash gravatar imagemohanprakash ( 2014-04-09 13:29:55 -0500 )edit

I followed the instructions on http://docs.fedoraproject.org/en-US/Fedora/20/html/Installation_Guide/Making_USB_Media.html

So, from windows, i downloaded the liveusb-creator and browsed for the downloaded iso and installed to the the previously formatted usb stick.

sea gravatar imagesea ( 2014-04-14 17:40:07 -0500 )edit
2

That is a Fedora 20 guide. Don't you think it would be better for you to use a Fedora 20 image instead of Fedora 17?

mohanprakash gravatar imagemohanprakash ( 2014-04-22 13:15:50 -0500 )edit

"secure boot not enabled" is printed by the boot loader included with Fedora, not the firmware. In other words, Secure Boot is already disabled, and the computer has already started Fedora. The error has nothing to do with Secure Boot.

QuLogic gravatar imageQuLogic ( 2014-08-06 00:02:46 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-08-05 16:30:05 -0500

deadrat gravatar image

Secure Boot is a security standard to make sure that your PC boots using only software that is trusted by the PC manufacturer. This is activated by default in some PCs which ships with Windows 2012, 8 or later.

Most of the computers have option to disable secure boot and it is found under PC’s firmware (BIOS) menus. It can be launched by pressing "F2" during the boot.

Most PCs recognize Fedora 20, so try booting with Fedora 20 instead of 17. But if you really want 17, before you disable Secure Boot, consider reading the page : http://technet.microsoft.com/en-in/library/dn481258.aspx

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-01-30 20:36:51 -0500

Seen: 400 times

Last updated: Aug 05 '14