Ask Your Question
1

Post BIOS Pre Login Dual Monitor Configuration [Fedora 23]

asked 2016-04-08 22:23:01 -0600

jabocg gravatar image

I've been having this issue since I started using Fedora 21, and have yet to find a solution.

I have two identical monitors, both using DVI cables, plugged into one of my two GeForce GTX 670 cards. The BIOS knows that Monitor 1(on the left, top DVI slot on the card) is the primary. GRUB knows that Monitor 1 is the primary. When Fedora is starting up, the monitors are cloned. However, when Fedora is at the login screen, the RIGHT monitor is considered the primary(and also thinks it's to the left of the left monitor). A short while after logging in, it clones the monitors again. Finally, when I am logged in and my settings have loaded, everything returns to normal.

I have tried creating a new config file in /etc/X11/xord.conf.d.
I have tried using xrandr and related settings.

Any suggestions?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-04-10 10:42:42 -0600

dagger gravatar image

updated 2016-04-11 19:50:36 -0600

From the Arch wiki:

gdm is not configured by gnome display settings, resulting in the login screen not being displayed on the primary monitor. A workaround is explained here. It just consists in copying the user monitor configuration file to gdm's.

The "workaround" from the forum linked above:

Set up the primary / secondary monitors as a normal user (Settings / Displays), then copy the users ~/.config/monitors.xml to ~gdm/.config/

That said, I personally don't have a gdm directory in my home folder, so I don't know what the equivalent to ~gdm/.config/ would be on a Fedora machine. Maybe you need to mkdir gdm in your home folder and mkdir gdm/.config, then cp ~/.config/monitors.xml ~/gdm/.config/. Or maybe there is another gdm .config directory elsewhere where you need to put the xml file. Tough to tell exactly what the solution was from that post on the Arch forum. In any case, definitely seems like an issue with gdm (GNOME Display Manager) configuration.

Edit: As mentioned by @genodeftest there is a /var/lib/gdm/.config/ directory. Put the xml file in there and restart, and let us know if that solves the issue.

edit flag offensive delete link more

Comments

1

~gdm should be /var/lib/gdm on your machine, and it already has the .config folder in my case.

genodeftest gravatar imagegenodeftest ( 2016-04-11 16:52:45 -0600 )edit

Question Tools

Stats

Asked: 2016-04-08 22:23:01 -0600

Seen: 341 times

Last updated: Apr 11 '16