Ask Your Question
1

computer goes idle while watching movies in vlc

asked 2011-11-07 07:15:36 -0600

hitz gravatar image

I have been facing this problem since two to three days. My computer goes idle while watching movie in vlc player and i have to authenticate it again and again . I have fedora14 on my machine!! can anyone suggest me with a solution .

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-08 06:07:28 -0600

Elad Alfassa gravatar image

VLC simply doesn't tell GNOME to inhibit the screensaver. It's a bug. Possible workarounds:

  • Disable screensaver
  • Move the mouse around once in a while
  • Use another video player
  • Make the screensaver timeout longer in your settings

Either use one of these workarounds, or report a bug.

edit flag offensive delete link more

Comments

Please report a bug. (and update to a supported release)

FranciscoD_ gravatar imageFranciscoD_ ( 2012-01-30 05:51:10 -0600 )edit
1

answered 2012-01-09 13:57:10 -0600

buff0k gravatar image

This problem existed in F15 as well, and still continues to exist in F16. It has to do with the X system as far as I can figure, as VLC does not sucesfully disengage the ScreenSaver system. My issue is that VLC blames Fedora (And apparantly rightly so, as it seems to work on pretty much any other distro), whereas Fedora finds it easier to blame VLC. I find it hard to imagine that such a common bug that has been known to exist since F14 already has not yet been adressed. Various workarounds exist but none cater to my requirements. I use VLC because of it's simple interface, allowing multiple instances and the fact that it plays everything. I want my PC to automatically engage sleep once a movie has finished playing because I use it in my bedroom as an entertainment system when I go to bed and mostly fall asleep while watching movies. Totem does not offer multiple instances and mplayer has the same interface as PowerDVD (Which I hate). At some stage someone should stop looking to place the blame (Which I suspect does lie with VLC and the way it completely fails to call the function correctly)

edit flag offensive delete link more
1

answered 2011-11-16 09:26:53 -0600

dmachop gravatar image

You have to be knowing that it has nothing to do with VLC Media Player. Moreover, it is just an option to adjust in your Power Settings. To do that :

  1. Go to System -> Preferences.

  2. In the bottom left corner, unselect the Second check box - Lock Screensaver when Inactive.

  3. Increase the Time bar as much as possible.
edit flag offensive delete link more
0

answered 2011-11-08 10:00:46 -0600

tuxdna gravatar image

If you are using GNOME on Fedora 14, you may want to set it in display/power preferences.

I also do it the same way.

edit flag offensive delete link more
0

answered 2012-01-09 23:37:37 -0600

ryran gravatar image

updated 2012-01-09 23:37:52 -0600

This won't help the original poster (on Fedora 14), but for others: A work-around for Gnome3 is the presentation-mode extension. Description from rpm:

Gnome-Presentation-Mode is a tiny gnome-shell extension that adds a new entry to the power indicator (the menu that opens when you click the battery icon). While presentation mode is on the screen saver and the automatic suspend will not kick in, allowing you to sit back and enjoy whatever you are doing without having to wiggle the mouse every few minutes.

Sadly, this doesn't help much in the scenario where you fall asleep watching a movie, but it's better than nothing. I've been meaning to code a little timer app to deal with this for a while now... just never seems important enough. Oh well.

yum install gnome-shell-extension-presentation-mode --enablerepo=updates-testing
edit flag offensive delete link more
0

answered 2011-11-16 01:47:40 -0600

kparal gravatar image

As for bug reporting: Fedora 14 will be unsupported in a month. It's probably better to upgrade, this will be hardly fixed when reported.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2011-11-07 07:15:36 -0600

Seen: 3,287 times

Last updated: Jan 09 '12