Ask Your Question
7

Firefox opens the Downloads folder using the wrong file browser, on systems with multiple desktop environments

asked 2016-04-03 18:28:20 -0600

terrycloth gravatar image

updated 2016-08-15 17:29:15 -0600

background

I have GNOME, KDE Plasma, and Cinnamon installed on my desktop, because I like playing around with the different desktop environments. I'd installed the normal Fedora Workstation image, which comes with GNOME, and then added the other desktops afterward by installing the "Cinnamon Desktop" and "KDE Plasma Workspaces" groups. I'm testing this on Fedora 24 (64-bit) with the latest updates -- so, Firefox 48.0, Nautilus 3.20.2, Dolphin 16.04.3, and Nemo 3.0.6.

As described here, Firefox has a recent downloads menu -- the downward-pointing blue arrow button -- which lists recent downloads. To the right of each listed file is a button to "Open Containing Folder," which is supposed to open the download folder using the default file manager.

the problem

When I first ran into this issue in Fedora 23, I noticed that Firefox would open the downloads folder with KDE's Dolphin, even when I was logged into GNOME Shell. Now, in Fedora 24, I'm having the opposite issue: Firefox opens the download folder with GNOME's Nautilus, even when I'm logged into KDE Plasma. For some reason, I've never had an issue with opening the wrong file browser in Cinnamon. The point, though, is that the file manager used does not match the desktop environment I'm running.

looking for possible causes / solutions

I open folders with the correct file manager in everything except Firefox, though. For example, in Transmission, I can right-click on the Fedora Workstation torrent, then click on "Open Folder," which launches Nautilus in GNOME and Dolphin in Plasma, like I would expect. And the xdg-open terminal command opens folders with Nautilus or Dolphin to match the currently active desktop environment, like I would expect. The "Show in folder" menu item for downloads in Google Chrome also calls the correct file manager.

I've tried looking at the inode/directory media type in all these files:

  • ~/.local/share/applications/mimeapps.list
  • ~/.config/mimeapps.list
  • /usr/share/applications/mimeapps.list
  • /usr/share/applications/mimeinfo.cache

...editing the inode/directory value does not seem make any difference at all in determining which file browser to use in any of the desktop environments, though. Even after running update-desktop-database and update-mime-database and rebooting.

I also tried running the command exo-preferred-applications while logged into KDE Plasma. In the window that popped open, there was no preferred file manager set. I set it to Dolphin, restarted Firefox, and tried "Open Containing Folder" in the recent downloads list again, but it still launches Nautilus in Plasma. So I'm not sure how to tell Firefox which file manager to use.

In my search on the web for solutions, I've seen some recommend replacing or renaming the Nautilus executable in /usr/bin, or replacing or renaming the Nautilus .desktop files. These are ugly hacks that prevent Nautilus from being usable at all -- and if I wanted that, I would just uninstall GNOME.

Any other ideas?

edit retag flag offensive close merge delete

Comments

Same issue here. I'd be interested in an answer too.

genodeftest gravatar imagegenodeftest ( 2016-04-04 11:44:05 -0600 )edit

I'm facing the same problem and couldn't find a workaround.

skytux gravatar imageskytux ( 2016-04-04 11:45:29 -0600 )edit

I can help you; but I need your answer; put here the output with the next text in terminal:

cat /usr/share/applications/mimeinfo.cache | grep  inode/directory
davidva gravatar imagedavidva ( 2016-07-16 02:22:29 -0600 )edit

Sorry for the delayed response; I messed up some things when I upgraded to Fedora 24 the other day.

After reinstalling Fedora and the desktop environments, I actually now have the opposite problem: Firefox opens the download folder using Nautilus, even when I'm currently logged into KDE Plasma.

$ cat /usr/share/applications/mimeinfo.cache | grep inode/directory inode/directory=org.kde.dolphin.desktop;org.kde.gwenview.desktop;nemo.desktop;easytag.desktop;git-cola-folder-handler.desktop;kde4-kfmclient_dir.desktop;org.gnome.Nautilus.desktop;org.gnome.baobab.desktop;

terrycloth gravatar imageterrycloth ( 2016-07-20 02:16:55 -0600 )edit

There is a bug report against Firefox: https://bugzilla.mozilla.org/show_bug...

genodeftest gravatar imagegenodeftest ( 2018-12-02 06:06:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-25 20:34:47 -0600

davidva gravatar image

updated 2016-07-25 20:43:50 -0600

@Chromosome ; sorry for the delay response haha.

su
sudo gedit /usr/share/applications/mimeinfo.cache

move

"org.gnome.Nautilus.desktop;org.gnome.baobab.desktop;"  after "inode/directory="

Result:

inode/directory=org.gnome.Nautilus.desktop;org.gnome.baobab.desktop;org.kde.dolphin.desktop;org.kde.gwenview.desktop;nemo.desktop;easytag.desktop;git-cola-folder-handler.desktop;kde4-kfmclient_dir.desktop;

now reboot your system...

edit flag offensive delete link more

Comments

Hm, that doesn't seem to have made any difference. Firefox still launches Nautilus even when logged into KDE Plasma.

terrycloth gravatar imageterrycloth ( 2016-07-25 23:47:29 -0600 )edit

Man! sort your mind, all people read the revision history https://ask.fedoraproject.org/en/ques... Well this question is "Firefox opens the Downloads folder using the wrong file browser." then you answer is relationated to firefox...

"When I'm logged into GNOME Shell, though, the Firefox downloads menu opens the folder with KDE's Dolphin, instead of GNOME's Nautilus. Nautilus does appear to be the default file manager in everything except Firefox, though." Then??? man...

davidva gravatar imagedavidva ( 2016-07-26 01:58:53 -0600 )edit

su

sudo gedit gedit /usr/share/applications/mimeapps.list

Replace

inode/directory=org.gnome.Nautilus.desktop

with your favorite file manager, using as guide my previous answer...

now

update-desktop-database /usr/share/applications
update-mime-database    /usr/share/mime
davidva gravatar imagedavidva ( 2016-07-26 02:41:35 -0600 )edit

Nope, the problem persists.

You're right, though, that I should update the original post instead of leaving the newest information in comments.

terrycloth gravatar imageterrycloth ( 2016-07-26 04:32:53 -0600 )edit

Question Tools

6 followers

Stats

Asked: 2016-04-03 18:28:20 -0600

Seen: 2,615 times

Last updated: Aug 15 '16