Ask Your Question
2

Fedora23+Cinnamon : Lock screen issue

asked 2016-03-23 04:52:46 -0600

jwhite gravatar image

updated 2016-03-26 07:06:53 -0600

Hi all,

I'm using Fedora 23, along with the cinnamon desktop. I set up the fingerprint reader which works fine.

When I lock the screen (Ctrl + Alt + L), and I try to unlock :

  1. the form to enter my password displays, but I can't type, and it says "please swipe your finger". Swiping my finger does nothing. After waiting 10 seconds, it says "Verification timed out", and I can type my password and login.

  2. If I click "Switch user", the screen goes black, and I can't do anything except hard-kill my machine by long-pressing the power button.

I tried to search online, but I'm too new to this ecosystem for this. Could you help me with :

  1. What log should I check ? system log ? gnome log ? cinnamon log ?

  2. Which program might be the cause of this ? does gnome have a special login program ? should I reinstall the graphic environment ?

Generally speaking, I don't know how to start tackling the problem.

Thanks a lot ! Jwhite

Edit 1

It looks like I'm already using GDM (and not lightDM). See the output of pstree :

     ├─gdm─┬─gdm-session-wor─┬─gdm-wayland-ses─┬─dbus-daemon───{dbus-daemon}
    │     │                 │                 ├─gnome-session-b─┬─gnome-settings-─┬─{dconf worker}
    │     │                 │                 │                 │                 ├─{gdbus}
    │     │                 │                 │                 │                 ├─{gmain}
    │     │                 │                 │                 │                 └─{pool}
    │     │                 │                 │                 ├─gnome-shell─┬─Xwayland─┬─{llvmpipe-0}
    │     │                 │                 │                 │             │          ├─{llvmpipe-1}
    │     │                 │                 │                 │             │          ├─{llvmpipe-2}
    │     │                 │                 │                 │             │          └─{llvmpipe-3}
    │     │                 │                 │                 │             ├─ibus-daemon─┬─ibus-dconf─┬─{dconf worker}
    │     │                 │                 │                 │             │             │            ├─{gdbus}
    │     │                 │                 │                 │             │             │            └─{gmain}
    │     │                 │                 │                 │             │             ├─ibus-engine-sim─┬─{gdbus}
    │     │                 │                 │                 │             │             │                 └─{gmain}
    │     │                 │                 │                 │             │             ├─{gdbus}
    │     │                 │                 │                 │             │             └─{gmain}
    │     │                 │                 │                 │             ├─{JS GC Helper}
    │     │                 │                 │                 │             ├─{JS Sour~ Thread}
    │     │                 │                 │                 │             ├─{dconf worker}
    │     │                 │                 │                 │             ├─{gdbus}
    │     │                 │                 │                 │             ├─{gmain}
    │     │                 │                 │                 │             └─{threaded-ml}
    │     │                 │                 │                 ├─{dconf worker}
    │     │                 │                 │                 ├─{gdbus}
    │     │                 │                 │                 └─{gmain}
    │     │                 │                 ├─{gdbus}
    │     │                 │                 └─{gmain}
    │     │                 ├─{gdbus}
    │     │                 └─{gmain}
    │     ├─gdm-session-wor─┬─gdm-x-session─┬─Xorg─┬─xf86-video-inte
    │     │                 │               │      └─{Xorg}
    │     │                 │               ├─cinnamon-sessio─┬─abrt-applet─┬─{gdbus}
    │     │                 │               │                 │             └─{gmain}
    │     │                 │               │                 ├─blueman-applet─┬─{dconf worker}
    │     │                 │               │                 │                ├─{gdbus}
    │     │                 │               │                 │                └─{gmain}
    │     │                 │               │                 ├─cinnamon-killer─┬─{dconf worker}
    │     │                 │               │                 │                 ├─{gdbus}
    │     │                 │               │                 │                 └─{gmain}
edit retag flag offensive close merge delete

Comments

Looks like you are running into this bug: https://bugzilla.redhat.com/show_bug....

genodeftest gravatar imagegenodeftest ( 2016-03-23 15:22:10 -0600 )edit

thanks for the link ! I'll keep watching it

jwhite gravatar imagejwhite ( 2016-03-26 06:23:35 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-03-23 14:04:18 -0600

Try changing your DM from lightdm to GDM. The moment your screen locks it is now a Display Manager issue, so that why the problem lies with the DM.

edit flag offensive delete link more

Comments

It looks like I'm already using GDM, see edit 1. (thanks for the answer btw!)

jwhite gravatar imagejwhite ( 2016-03-26 07:08:24 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-03-23 04:51:52 -0600

Seen: 666 times

Last updated: Mar 26 '16