Ask Your Question

NVIDIA Optimus/Bumblebee support Fedora

asked 2016-03-19 22:37:14 -0600

darknish gravatar image

So, I'd like to ask if any of you guys have succeeded in setting up/installing graphics drivers for a hybrid notebook, that uses the Optimus technology and, technically, would have to use Bumblebee support for it. Everytime I try to install Bumblebee and then, some driver, my drivers cease to work and I get a black screen and then I have to reinstall Fedora. I don't know what to do :p since I have tried to follow some guides/tutorial, but they all seem to fail and not work. Has anyone here succeeded in doing it and has a tutorial/guide for me to follow with a better chance of success? I've got Intel Internal Graphics and a NVIDIA Geforce 840M on the same notebook, and I'd like to have the 840 work, but I don't know how to test it (have tried some methods but can't remember them again right now) to see if it is working and handling the graphic stuff and I can't just install a graphic driver for it have it work, 'cause if I just do this, I get the black screen. Thanks!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2016-05-09 11:00:41 -0600

utkarsh009 gravatar image

updated 2017-02-12 07:44:24 -0600

It's working for me too.
Have a look at my blog:

Edit 1: Here's a sequel to the original post. Sequel

edit flag offensive delete link more

answered 2016-03-20 07:53:09 -0600

fcomida gravatar image

Have a look here:

It's working well here with Intel Corporation Haswell-ULT Integrated Graphics Controller and NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]

edit flag offensive delete link more

answered 2016-03-21 17:25:43 -0600

mosquito gravatar image

updated 2016-10-16 15:45:30 -0600

The official driver also supports 'Optimus'(don't support disable GPU). Please see the following URL.

NVIDIA 364.12 support Wayland/Mir, KMS, PRIME(Optiomus)

1.Install akmod-nvidia, require rpmfusion repo

  $ sudo dnf install akmod-nvidia

2.edit xorg.conf

$ sudo vim /etc/X11/xorg.conf
Section "Module"
    Load "modesetting"     # /usr/lib64/xorg/modules/drivers/

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "<BusID for NVIDIA device here>"    # lspci | grep -E "VGA|3D"
    Option "AllowEmptyInitialConfiguration"

3.For the GDM(GNOME3) display manager create a new .desktop file

$ sudo vim /usr/share/gdm/greeter/autostart/display_setup.desktop
[Desktop Entry]
Name=Display setup
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
edit flag offensive delete link more


Not original poster, but the arch link you gave says that the oficial nvidia driver doesn't give gpu switching, which is usefull to save battery on a laptop and is the point of optimus.

EDIT: but you say the new driver does, ok

HoboPrimate gravatar imageHoboPrimate ( 2016-03-23 13:35:44 -0600 )edit

The official nvidia driver don't support disable GPU. :-(

The NVIDIA driver currently only supports the Source Output capability. It does not support render offload and cannot be used as an output sink.

mosquito gravatar imagemosquito ( 2016-10-16 15:41:12 -0600 )edit

Question Tools

1 follower


Asked: 2016-03-19 22:37:14 -0600

Seen: 7,013 times

Last updated: Feb 12 '17