Ask Your Question

How to setup internet connection on fedora 21?

asked 2016-03-19 09:00:09 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi all, I have fedora 21 installed on my pc along side with Windows 7 in a Dual boot configuration. I'm unable to setup internet connection and use the internet. After clicking on the network icon and choosing the "Wired" option, I clicked on the "Add Profile" button and filled up the fields DNS, IP, Netmask, Gateway with the values given to me by my internet service provider & clicked on "Apply" button. The network icon is always showing connecting but nothing is happening. However in Windows I can access internet using those same setup data. Any help will be much appreciated. Thanks in Advance.

edit retag flag offensive close merge delete


no body wants to help?? :D :D

CompEnthusiast gravatar imageCompEnthusiast ( 2016-03-20 02:49:33 -0600 )edit

When network icon shows "connecting", as root user, issue the command dmesg in a terminal and post the output here.

anishjp gravatar imageanishjp ( 2016-03-20 12:17:07 -0600 )edit

Try uninstalling your current driver and installing a new one.

RealPlayerCraft gravatar imageRealPlayerCraft ( 2016-03-20 14:38:46 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-03-20 09:22:09 -0600

genodeftest gravatar image

Normally fedora should be automatically connecting to the internet on LAN. Can you try this:

  1. remove your LAN cable
  2. delete the profile
  3. reattach your LAN cable

Are you directly connecting to the internet or do you have a router or cable modem? Does running ping in a terminal work?

PS: as soon as you got your internet connection running you probably should update to Fedora 22 or 23 since there are no updates for Fedora 21 any more.

edit flag offensive delete link more

answered 2016-03-26 09:52:02 -0600

CompEnthusiast gravatar image

Hi all,after having few days of headache it seems that I might have solved my issue myself.Just out of curiosity I just changed my IP settings from automatic to Manual and keeping the automatic options for DNS and Routes as "Off" and "On" respectively(they were also same earlier although) and reverted back to Wired settings window,refreshed it,and to my surprise,Yipeeeeeeeee..... my Fedora 21 installation is now up and running as it should. :D :D :D :D

edit flag offensive delete link more

Question Tools


Asked: 2016-03-19 09:00:09 -0600

Seen: 1,588 times

Last updated: Mar 20 '16