Ask Your Question
0

asus driver issue

asked 2016-03-18 01:00:04 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I install fedora 23 on the asus lvivobook e200ha however the wireless is not working and touch panel can not be setting. and no sound. I try the ubuntu because I found this:askubuntu.com/questions/708061/qualcomm-atheros-device-168c0042-rev-30-wi-fi-driver-installation
I fellow it step by step however it change nothing. so i reinstall the fedora. and wander if there is any solution. I'd be grateful for any hints, and will provide information about my system if required.

lspci information

00:00.0 Host bridge: Intel Corporation Device 2280 (rev 22)

00:02.0 VGA compatible controller: Intel Corporation Device 22b0 (rev 22)

00:0b.0 Signal processing controller: Intel Corporation Device 22dc (rev 22)

00:14.0 USB controller: Intel Corporation Device 22b5 (rev 22)

00:1a.0 Encryption controller: Intel Corporation Device 2298 (rev 22)

00:1c.0 PCI bridge: Intel Corporation Device 22c8 (rev 22)

00:1f.0 ISA bridge: Intel Corporation Device 229c (rev 22)

01:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 30)

all the red part from dmesg

[    1.766112] i8042: Can't read CTR while initializing i8042

[    7.900074] i2c_hid i2c-PDEC3393:00: error in i2c_hid_init_report size:7 / ret_size:4

[    7.907198] i2c_hid i2c-PDEC3393:00: error in i2c_hid_init_report size:19 / ret_size:4

[    8.049385] i2c_hid i2c-FTE1000:00: error in i2c_hid_init_report size:633 / ret_size:7

[    8.054149] i2c_hid i2c-FTE1000:00: error in i2c_hid_init_report size:131 / ret_size:7

[    8.129680] intel_sst_acpi 808622A8:00: No matching machine driver found

[    8.852411] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-5.bin': -2

[    8.852438] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-4.bin failed with error -2

[    8.852445] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-4.bin': -2

[    8.852467] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-3.bin failed with error -2

[    8.852474] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-3.bin': -2

[    8.852497] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-2.bin failed with error -2

[    8.852503] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-2.bin': -2

[    8.852551] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware.bin failed with error -2

[    8.852558] ath10k_pci 0000:01:00.0: could not fetch firmware (-2)

[    8.852564] ath10k_pci 0000:01:00.0: could not fetch firmware files (-2)

[    8.852569] ath10k_pci 0000:01:00.0: could not probe fw (-2)

[  243.933908] i915 0000:00:02.0: Invalid ROM contents

[ 2436.664333] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=145000 end=145001) time 419 us, min 763, max 767, scanline start 755, end 775
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-18 03:00:18 -0600

geforce gravatar image

You need the firmware

see

https://askubuntu.com/questions/72104...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-03-18 01:00:04 -0600

Seen: 744 times

Last updated: Mar 18 '16