Ask Your Question
1

Strange Touchpad behaviour since 2 days (mar 14th) in F23

asked 2016-03-16 13:23:32 -0600

ceres2009 gravatar image

updated 2016-03-17 23:21:49 -0600

mether gravatar image

I have a strange issue on my T450s Lenovo Laptop using F23 with Gnome on X. Everything was working brilliant from day 1 with the touchpad. Since evening of 14th of march (UTC) the touchpad is behaving strangely:

  1. in intervals the tap to click and two-finger scroll won't work in complete firefox and other apps especially Gnome buttons, windows Max, Min etc.
  2. when i physically click on the whole touchpad everything is fine again for a few seconds
  3. then it starts again to not Tap-to-click -> 1.

i'm clueless has anybody an idea how this came?

edit retag flag offensive close merge delete

Comments

Have you tried booting an older kernel? How does the touchpad behave there?

florian gravatar imageflorian ( 2016-03-16 13:52:26 -0600 )edit

Hi florian, great idea didn't try yet, but found the following in syslog exactly when it starts: mycomputer.localdomain /usr/libexec/gdm-x-session[2081]: (EE) libinput bug: unexpected scroll event 0 in area state Only thing related i find searching is https://bugzilla.redhat.com/show_bug.cgi?id=1209151 But this is from a year ago and slightly different as there are also other events (two/three finger taps) registered by libinput.

ceres2009 gravatar imageceres2009 ( 2016-03-16 14:40:54 -0600 )edit

i started the previous kernel: 4.4.3-300.fc23.x86_64 #1 SMP Fri Feb 26 18:45:40 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux same behavior - same error message in the log. Can i revert / downgrade libinput to an earlier version?

ceres2009 gravatar imageceres2009 ( 2016-03-16 17:14:18 -0600 )edit

Yes, you can try that. Citing from man dnf:

Downgrade Command: dnf [options] downgrade <package-installed-specs>: Downgrades the specified packages to the highest of all known lower versions if possible. When version is given and is lower than version of installed package then it downgrades to target version.

So, in your case it would be sudo dnf downgrade libinput. That would mean you go one version lower than the currently installed one (and which is most likely the one you had installed previously).

florian gravatar imageflorian ( 2016-03-17 10:01:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-04-04 13:06:51 -0600

sn00p gravatar image

This bug was introduced in "libinput" package 1.2.2-1 version and was fixed few days ago only.

Bug discussion is here.

dnf downgrade libinput --allowerasing should solve this issue until Fedora upstream catch the fix.

edit flag offensive delete link more

Comments

thanks, sn00p for the info. i didn't try downgrading libinput yet. thx florian for the tipp!

Best, CereS

ceres2009 gravatar imageceres2009 ( 2016-04-04 15:21:36 -0600 )edit

Question Tools

Stats

Asked: 2016-03-16 13:23:32 -0600

Seen: 122 times

Last updated: Apr 04 '16